Solved

cfgrid type="xml" not working... or using correctly?

Posted on 2007-04-04
4
364 Views
Last Modified: 2013-12-24
Hi,

I cannot get this to work.  I am using Coldfusion 7.0. Any ideas?
___________________________________________________________

<cfquery name="obtain" datasource="esp">
SELECT #form.querystructure#
FROM tbl_pav2

</cfquery>

<cfform>
<cfgrid format="xml" query="obtain" name="obtain" width="100%" height="700" >
</cfgrid>
0
Comment
Question by:esphelpdesk
  • 3
4 Comments
 

Author Comment

by:esphelpdesk
Comment Utility
The query has data in it, and works perfectly when I use the applet or the flash format.  Is this a bug in the application?  This is the source code that is returning:



______________________________________________________________________________________






<script type="text/javascript" src="/CFIDE/scripts/cfform.js"></script>
<script type="text/javascript" src="/CFIDE/scripts/masks.js"></script>
<script type="text/javascript">
<!--
function _CF_checkCFForm_1(_CF_this)
{
//reset on submit
_CF_error_exists = false;
_CF_error_messages = new Array();
_CF_error_fields = new Object();
_CF_FirstErrorField = null;


//display error messages and return success
if( _CF_error_exists )
{
if( _CF_error_messages.length > 0 )
{
// show alert() message
_CF_onErrorAlert(_CF_error_messages);
// set focus to first form error, if the field supports js focus().
if( _CF_this[_CF_FirstErrorField].type == "text" )
{ _CF_this[_CF_FirstErrorField].focus(); }

}
return false;
}else {
return true;
}
}
//-->
</script>














<form name="CFForm_1" action="/reports/rpt_PAV_select_p2.cfm" method="post" onsubmit="return _CF_checkCFForm_1(this)">

















<div><input type="hidden" name="__CFGRID__CFForm_1__obtain" value="" /></div>
</form>

0
 
LVL 36

Accepted Solution

by:
SidFishes earned 500 total points
Comment Utility
not sure but i think you must specify xml as the format for your cfform as well

0
 

Author Comment

by:esphelpdesk
Comment Utility
No... that isn't it.  I am thinking the tag doesn't work.  I am looking for a confirmation on this.
0
 

Author Comment

by:esphelpdesk
Comment Utility
I wish to close this ticket.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

One of the typical problems I have experienced is when you have to move a web server from one hosting site to another. You normally prepare all on the new host, transfer the site, change DNS and cross your fingers hoping all will be ok on new server…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now