cfgrid type="xml" not working... or using correctly?

Hi,

I cannot get this to work.  I am using Coldfusion 7.0. Any ideas?
___________________________________________________________

<cfquery name="obtain" datasource="esp">
SELECT #form.querystructure#
FROM tbl_pav2

</cfquery>

<cfform>
<cfgrid format="xml" query="obtain" name="obtain" width="100%" height="700" >
</cfgrid>
esphelpdeskAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

esphelpdeskAuthor Commented:
The query has data in it, and works perfectly when I use the applet or the flash format.  Is this a bug in the application?  This is the source code that is returning:



______________________________________________________________________________________






<script type="text/javascript" src="/CFIDE/scripts/cfform.js"></script>
<script type="text/javascript" src="/CFIDE/scripts/masks.js"></script>
<script type="text/javascript">
<!--
function _CF_checkCFForm_1(_CF_this)
{
//reset on submit
_CF_error_exists = false;
_CF_error_messages = new Array();
_CF_error_fields = new Object();
_CF_FirstErrorField = null;


//display error messages and return success
if( _CF_error_exists )
{
if( _CF_error_messages.length > 0 )
{
// show alert() message
_CF_onErrorAlert(_CF_error_messages);
// set focus to first form error, if the field supports js focus().
if( _CF_this[_CF_FirstErrorField].type == "text" )
{ _CF_this[_CF_FirstErrorField].focus(); }

}
return false;
}else {
return true;
}
}
//-->
</script>














<form name="CFForm_1" action="/reports/rpt_PAV_select_p2.cfm" method="post" onsubmit="return _CF_checkCFForm_1(this)">

















<div><input type="hidden" name="__CFGRID__CFForm_1__obtain" value="" /></div>
</form>

0
SidFishesCommented:
not sure but i think you must specify xml as the format for your cfform as well

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
esphelpdeskAuthor Commented:
No... that isn't it.  I am thinking the tag doesn't work.  I am looking for a confirmation on this.
0
esphelpdeskAuthor Commented:
I wish to close this ticket.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.