Solved

Crystal Viewer Toolbar... Simple Problem

Posted on 2007-04-04
12
726 Views
Last Modified: 2016-08-29
www.fundtrackersql.com/Auth/SchoolReports.aspx

UserName: testschool
Password: test

The grey color on the crystal report viewer toolbar is only going out to the point where the report goes out to.  Most of the time this doesn't go as far as it should thus leaving part of the toolbar as white which is an error.  

Does anyone have a fix for this... maybe something i can set in a css class for the toolbar, etc.  

Tony
0
Comment
Question by:picsnet
  • 6
  • 5
12 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 18852535
I don't see the problem.

The toolbar seemed complete eve when the grey bar was only 2/3rds across the screen.

The toolbar itself was fully grey.  Only the area to the right of the report was white.

mlmcc
0
 
LVL 1

Author Comment

by:picsnet
ID: 18852864
just delete it.  the login info isn't going to be there. that wasn't the right answer.  the problem is there.  
0
 
LVL 1

Author Comment

by:picsnet
ID: 18857609
Sorry mlmcc, I had several questions up for deletion and when i saw administrator comment i thought this was one of them.  

The problem is there though.  I definitely see it.  The problem isn't there in firefox.  It is there in ie 7.  If you view the reports:  Class Summary By Student and then File Page... You will see that Class Summary By Students toolbar color shrunk with the size of the report.  

I hope that you can take a look again and maybe have an answer.  

Thanks, Tony

p.s. I don't know if ie6 displays the same behavior.  
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 18858125
I am using IE6 on this machine.  There are some problems with Crystal and IE7.  I had iE7 on my other machine but uninstalled it to see if it would solve a different problem I had.

I don't find anything on the Crystal site.

Can yo post a screen shot at www.ee-stuff.com

mlmcc
0
 
LVL 1

Author Comment

by:picsnet
ID: 18858236
Here you go:  https://filedb.experts-exchange.com/incoming/ee-stuff/3100-DevMachine.gifhttps://filedb.experts-exchange.com/incoming/ee-stuff/3101-ServerMachine.gif


Hi, could you also try to look at this question: http://www.experts-exchange.com/Programming/Languages/.NET/ASP.NET/Q_22492299.html

I think you looked at a similar question once before.  I reposted after I got my load report problem fixed.  I had to give network service list permissions to c:/windows/temp.  This crystal stuff has been a nightmare so far.  I'm a newbie at it.  

You're an admin... Is it legal to solicit paid help on here.  I don't know if anyones going to want to put enough time in to help me with the toolbar button issue without pay.  

Thanks very much, Tony
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 18859377
No, it is against EE rules to solicit for help.  However experts are allowed to post in their profiles and indicate they are willing to help inthat way.  Simply click an experts name and you will see their profile.

mlmcc
0
 
LVL 1

Author Comment

by:picsnet
ID: 18859428
Did you have any ideas about the toolbar.  There is a crtoolbar class in the crystalviewer stuff that is in aspnet_client.  I added a few different properties to try and make it display properly, but none worked.  

Tony
0
 
LVL 1

Author Comment

by:picsnet
ID: 18859453
Would it be too much to ask to get this question and the other one I had you looked at moved into the crystal area too.  It might need to be removed from one of the other areas.  I searched other day, but couldn't find a crystal area.  I was looking in the wrong place.  

Tony
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 18859691
It would but a better idea is to post a question in the Crystal area that links to these 2.  This is because it will not show as a new question in the Crystal area.

I'll post the linking q.

mlmcc
0
 
LVL 1

Author Comment

by:picsnet
ID: 18875151
I guess I'll take this answer for now.  it is css in ie7 that is the issue, though I haven't found anyone who knows a fix for it.  Being css there should be a fix that someone could put in, but its taking the time to find it.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 18875286
Glad i could help

mlmcc
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article shows how to use the open source plupload control to upload multiple images. The images are resized on the client side before uploading and the upload is done in chunks. Background I had to provide a way for user…
Real-time is more about the business, not the technology. In day-to-day life, to make real-time decisions like buying or investing, business needs the latest information(e.g. Gold Rate/Stock Rate). Unlike traditional days, you need not wait for a fe…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question