Solved

how to make jmod_jk.so /jmod_jk2.so support on apache that installed with package called Xampp 1.6 for linux

Posted on 2007-04-04
12
685 Views
Last Modified: 2013-12-16
Hi All,
I need to setup  mod_jk module on Xampp 1.6  (/opt/lampp/modules/mod_jk2.so  or  /opt/lampp/modules/mod_jk.so)  with Xampp package to work in jsp under linux I am using fedora core 4.
please help me .
I get this error when I restart Xampp and when I connect to http://localhost:8080 I get an error say
"the  connection was refused to connect to http://localhost:8080"
and after making the configuration that exist with the addon of  Xampp package for tomcat  I get this error :

httpd: Syntax error on line 516 of /opt/lampp/etc/httpd.conf: Syntax error on line 1 of /opt/lampp/etc/tomcat.conf: Cannot load /opt/lampp/modules/mod_jk2.so into server: /opt/lampp/modules/mod_jk2.so: undefined symbol: apr_pool_get_parent
0
Comment
Question by:shang3000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 8

Accepted Solution

by:
frashii earned 500 total points
ID: 18855319
What version of Linux ? Do you have the libapr installed ?

Try one of the following (These might work, but it depends on what linux distro)

rpm -qa --queryformat '%{name-%{version}-%{release}' | grep libapr
dpkg --list | grep libapr

If it is not installed, lets install it, if it is, we can troubleshoot from there.

0
 

Author Comment

by:shang3000
ID: 18956668
Hi frashii,
>>>What version of Linux ?
fedora core 4
>>> Do you have the libapr installed ?
I don't know would you please tell me how to check out that issue

>>>Try one of the following (These might work, but it depends on what linux distro)

>>> rpm -qa --queryformat '%{name-%{version}-%{release}' | grep libapr
>>> dpkg --list | grep libapr
please give me the correct syntax since I'm new to linux

if you could help me to solve this problem that would be great
Best Regards
HG
0
 
LVL 8

Assisted Solution

by:frashii
frashii earned 500 total points
ID: 18996243
Fedora Core 4 is a rpm based system, therefore the following should work :)

rpm -qa --queryformat '%{name}-%{version}\r\n' | grep libapr

if that doesn't produce anything that is okay too, that can tell us what we need to know
0
Percona Live Europe 2017 | Sep 25 - 27, 2017

The Percona Live Open Source Database Conference Europe 2017 is the premier event for the diverse and active European open source database community, as well as businesses that develop and use open source database software.

 

Author Comment

by:shang3000
ID: 19014645
please give me what to write instead of %{name}-%{version} i wrot the following and it displayed nothing
[root@shang ~]# rpm -qa --queryformat '%{name}-%{version}\r\n' | grep libapr
[root@shang ~]#
0
 
LVL 8

Assisted Solution

by:frashii
frashii earned 500 total points
ID: 19029106
That means you don't have libapr installed :)

Try

yum install libapr

then, re-install mod_jk
0
 

Author Comment

by:shang3000
ID: 19064765
Hi frashii,
here is the try and the results:

[hatem@shang ~]$ su
Password:
[root@shang hatem]# yum install libapr
Setting up Install Process
Setting up repositories
Cannot find a valid baseurl for repo: updates-released
[root@shang hatem]#

please guide me what to  do with an example of  that describe the syntax

Best Regards
HG
0
 
LVL 8

Assisted Solution

by:frashii
frashii earned 500 total points
ID: 19120077
HG,

Look at the file /etc/yum.repos.d/fedora-updates.repo

Is the baseurl for updates-released commented out ? If so, remove the # at the beginning of the line and try again.
0
 

Author Comment

by:shang3000
ID: 19122375
Hi frashii,
this is the basurl line that I uncommented
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch/
when trying that command
yum install libapr

I got this error
Setting up Install Process
Setting up repositories
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: updates-released
failure: repodata/repomd.xml from updates-released: [Errno 256] No more mirrors to try.

please help
Best Regards
HG
0
 
LVL 8

Assisted Solution

by:frashii
frashii earned 500 total points
ID: 19122678
Do you have your DNS server defined in /etc/resolv.conf ?

There should be one or more lines like :

nameserver 192.168.1.1
nameserver 192.168.1.2

Add or change them to point to a working DNS server. and re-try the command.
0
 

Author Comment

by:shang3000
ID: 19122806
hi frashii,
here is the /etc/resolve.conf after modifications

; generated by NetworkManager, do not edit!
; Use a local caching nameserver controlled by NetworkManager
nameserver 127.0.0.1
nameserver 192.168.0.208

and here is the command and error
[root@shang hatem]# yum install libapr
Setting up Install Process
Setting up repositories
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: updates-released
failure: repodata/repomd.xml from updates-released: [Errno 256] No more mirrors to try.
[root@shang hatem]#

I hope you can you help me in that situation
Best Regards
HG
0
 
LVL 8

Assisted Solution

by:frashii
frashii earned 500 total points
ID: 19139117
It looks like your DNS is not working correctly.

Try the following command:

dig download.fedora.redhat.com

If this results in an error, use the gnome control panel for NetworkManager and adjust the DNS server to something that can resolve it.

if you can't make that work, as a VERY LAST RESORT add the following to your /etc/hosts file (we _really_ need to get DNS working rather than hack around it) :

209.132.176.20   download.fedora.redhat.com
0
 

Author Comment

by:shang3000
ID: 19171018
Hi frashii,
here is the result
[root@shang hatem]# dig download.fedora.redhat.com
; <<>> DiG 9.3.1 <<>> download.fedora.redhat.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 13725
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;download.fedora.redhat.com.    IN      A

;; Query time: 1822 msec
;; SERVER: 192.168.0.208#53(192.168.0.208)
;; WHEN: Tue May 29 12:38:45 2007
;; MSG SIZE  rcvd: 44

i opened /etc manually and added the line
209.132.176.20   download.fedora.redhat.com as you said

what is the  next  step to do
Best Regards
HG
0

Featured Post

WordPress Tutorial 4: Recommended Plugins

Now that you have WordPress installed, understand the interface, and know how to install new parts, let’s take a look at our recommended plugins.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question