Using SBS server with RAS behind a Lynksys Router

Hello, I have a SBS 2003 that I use for Active Directory and file serving. It is hooked up behind a lynksys  WRT4G router which also controls the internet service for all my clients.

I would like to enable a VPN connection to my network and would like to use the RAS capabilities of my server.  My question is this: I am I able to use my existing router and create a rule forwarding what ever ports I need to the server or must I enable the server itself as the router.  If possible I would like to keep my existing router as I have a number of fairly complicated access restrictions set up and working just fine. I would hat to have to redo all my work using the 2003 server as the router.

Thanks
LVL 2
JakeBushnellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AndrewCinkCommented:
You should have no problem with enabling the service on your windows box, and then set up "Port Forwarding" in the Linksys router, send the ports you need forwarded to the LAN IP of your server. If you are using Remote Desktop you would forward TCP_3389 to your Server's IP. Be careful of opening or forwarding any ports you don't know for sure you need open.

So yes, this should work just fine, but you will need to make sure the traffic from the outside world is port forwarded to the server, and that the service is running the required services.

Andy
0
JakeBushnellAuthor Commented:
Do you know what other ports besides tcp_3389 might need to be forwarded? I already have the RDP protocol forwarded for general use but I thought a VPN would require more.

0
Rob WilliamsCommented:
For the VPN you need only port 1743 forwarded. However, you also need to enable GRE, protocol 47 (not port 47), pass through. On your router this is done by checking "enable PPTP pass-through" I believe located in the firewall section.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

Rob WilliamsCommented:
A little more info on configuring:
The basic server and client configurations can be found at the following sites with good detail:
Server 2003 configuration:
http://www.onecomputerguy.com/networking/w3k_vpn_server.htm
Windows XP client configuration:
http://www.onecomputerguy.com/networking/xp_vpn.htm
You will also have to configure the router to forward the VPN traffic to the server. This is done by enabling on your router VPN or PPTP pass-through, and also forwarding port 1723 traffic to the server's IP. For details as to how to configure the port forwarding:
http://www.portforward.com/english/routers/port_forwarding/Linksys/WRT54G/Point-to-Point_Tunneling_Protocol.htm
The only other thing to remember is the subnet you use at the remote office needs to be different than the server end. For example if you are using 192.168.1.x at the office , the remote should be something like 192.168.2.x

Once this is configured you can then use services similar to how you would on the local network. You will not be able to browse the network unless you have a WINS server installed. Also depending on your network configuration you may have problems connecting to devices by name, though this can usually be configured.. Using the IP address is less problematic such as \\192.168.1.111\SharenName.
0
JakeBushnellAuthor Commented:
Thanks a lot folks!

 I got it running last night after fowarding the ports mentioned.
Jacob
0
Rob WilliamsCommented:
Thanks Jacob. Glad to hear.
Cheers !
--Rob
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.