Access via FTP to Website on Server 2003

I have configured Windows Server 2003 to be a web server.  I have also created a website on that server that is now visible on the web.  Now, what i want to do, is to be able to access this website using FTP, so i can edit the site in Dreamweaver or FrontPage or CuteFTP or any FTP-based program that gives me remote access.  As a start, I am able to log on using my Administrator username and password, but i can't see or edit any files.  I also want to instead be able to log on with DIFFERENT credentials than my Administrator account, say with the username of "ftpuser" instead.

I've read a ton of "Setting Up User Accounts for FTP" articles here, but none of them seem to apply to my present situation.  All i want to do is to be able to create a usename and password and then use that username and password to upload/download my files to/from my website and to view the ones that are there.

Can someone take me through this step-by-step? - Thanks in advance!
Who is Participating?
cleversleyConnect With a Mentor Author Commented:
1. Go to “System > Local Users and Groups > Users”
2. Right Click on “Users > New User…”
3. User Name and Full Name = “ftpuser”
4. Choose password, and choose “Password never expires”
5. Go to “Member of” tab, and click “Add”.
6. Add “Administrators” to the list.
7. Leave everything else at default settings and close out of the window.

1. Go to IIs Manager and expand until you get to "FTP Sites > Default FTP Site"
2. Right-click "Default FTP Site > Permissions.."
3. Click on "Security Accounts" tab an UN-check "Allow anonymous connections"
4. On "Home Directory" tab choose "c:\inetpub\ftproot" (or whatever drive it's on.)
5. Close window and single-click on "Default FTP Site"
5. Click on "Action > New > Virtual Directory..." in the menu.
6. Add "ftpuser" as Alias, and for Path, add the path to the directory you want FTP access for.
7. Close out of the window and make sure "ftpuser" appears under "Default FTP Site"

After completing both of the above steps, simply go to your FTP program with “ftpuser” and the password you created...and login!
have you read this one? it was the best i came accross
cleversleyAuthor Commented:
Yes, I have read that, and that's why I posted this question.  I am not setting up an FTP site; I only want to  create a user account that will let me upload/download files to my exisiting website on my dedicated server.  I've read the above article, I've read "To set up FTP accounts for known users" at MS-KB, and have also read as many questions that were answered here as I could find, but none that explained how my website, hosted on our own server, can simply have access to upload/download via any FTP program.  In IIs, under the "FTP Site" I chose "Actions > Properties" and disabled "Allow Anonymous Access".  I then created a new "Virtual Directory" which points to my website folder, and called it "ftpuser".  I made sure that "ftpuser" had the 3 boxes checked.  I then tried to log in using an FTP program, but could still only log in under the Administrator Account and password, but even then, i could see no files or folder.
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

cleversleyAuthor Commented:
Leave me to my own devices long enough, and I'll usually find the I allowed to answer my own questions here?  - Anyway, hopefully the steps above with anyone else who happens to be in the same frustrating position I found myself in.
Works for me
Closed, 500 points refunded.
Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.