Asp.net website administration tool security tab not working

I have VS 2005 professional edition and sql server 2005 enterprise edition installed to my pc. when I click on asp.net website administration tool and security tab, I get this error
There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.

What do I need to do?
jaws1021Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

samtran0331Commented:
0
jaws1021Author Commented:
Thank you for the link, it solved my problem, but I don't know how putting this code make that much difference? And when I run the application still put another connectionstring automatically but didn't effect anything.

<configuration>
 <connectionStrings>
<remove name=”LocalSqlServer”/>
  <add name="LocalSqlServer" connectionString="Data Source=localhost;Initial Catalog=appservicesdb;Integrated Security=True" providerName="System.Data.SqlClient"/>
</connectionStrings>
</configuration>

0
jaws1021Author Commented:
Also, why it is showing asp.net configuration setting? We don't change anything on that...
0
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

samtran0331Commented:
...you're trying to use "full" sql2005 right?
without that section in your web.config, the application tries to use the default db and location, which would be a sql express db and located in your app_data folder

>>why it is showing asp.net configuration setting
where?
0
hpolatCommented:
Thank you for your explaination, also do we need to leave code put there automatically or should delete it?
Right before the code, it is showing asp.net configuration setting dialog box, I was wondering why it show that?
0
jaws1021Author Commented:
Sorry, if question above is stupid for you, we are newbie on .net and sql 2005 just trying to learn it.
0
samtran0331Commented:
don't be sorry! we all start somewhere!

>>Thank you for your explaination, also do we need to leave code put there automatically or should delete it?
--You need to leave that section in your web.config just like the tutorial or else without it, your application will look for the default sql express database (which I assume you're not using)

>>Right before the code, it is showing asp.net configuration setting dialog box, I was wondering why it show that?
--I'm still unsure where you see a dialog box
0
jaws1021Author Commented:
thank you for being patient with us. You know the blog link you gave above when I click that and follow thru scroll down right above this code , has Asp.Net Configuration Settings Box there, we didn't understand why it is shown there even though doesn't say to do something on it? Is that made more sense now?

<configuration>
 <connectionStrings>
<remove name=”LocalSqlServer”/>
  <add name="LocalSqlServer" connectionString="Data Source=localhost;Initial Catalog=appservicesdb;Integrated Security=True" providerName="System.Data.SqlClient"/>
</connectionStrings>
</configuration>
0
jaws1021Author Commented:
O also you are not using sql server express
0
jaws1021Author Commented:
I am sorry. I meant above we are not using sql server express :)
0
samtran0331Commented:
i see.

In the article, the author is just showing you that there is another way to edit the web.config.
Either you can do it manually by putting that chunk of code in your web.config.

or you can use IIS in which case, you will see that Asp.Net Configuration Settings Box .
if you go to IIS and go to the properties of your application and then click on the asp.net tab and then click the "Edit Configuration" button, you will see that dialog box and from there, you can edit almost all the settings of the web.config file without actually opening the web.config file in a text editor.

so it's in the article only because the author wanted to show you that editing the web.config can be done through IIS (in previous versions of .Net, this was not true)

And because you are *not* using SQL Express and the default database and settings, that is exactly why you have to have:
<connectionStrings>
<remove name=”LocalSqlServer”/>
  <add name="LocalSqlServer" connectionString="Data Source=localhost;Initial Catalog=appservicesdb;Integrated Security=True" providerName="System.Data.SqlClient"/>
</connectionStrings>


that section in the web.config says:
"remove the default settings and use my settings"

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jaws1021Author Commented:
Thank you! you were a good help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.