Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Changing ethernet setting permanently on Red Hat Linux

Posted on 2007-04-05
5
319 Views
Last Modified: 2013-12-06
I used the following command to change the settings on eth0:

ethtool -s eth0 autoneg off
ethtool -s eth0 speed 10
ethtool -s eth0 duplex full

This did indeed change my settings, but when the linux server was rebooted, it reverted back to:
autoneg on
duplex half

How do I make the change permanent?
0
Comment
Question by:mhorrocks
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:cheesygit182
ID: 18861531
What distro you are using?

~cheesygit182
0
 

Author Comment

by:mhorrocks
ID: 18920928
Question no longer valid.  Need to delete the question.

Would like to offer cheesygit182 100 points for at least responding to the question.
0
 
LVL 4

Accepted Solution

by:
cheesygit182 earned 500 total points
ID: 18927272
hi, to delete the question, you need make a request here:
http://www.experts-exchange.com/Community_Support/General/newQuestionWizard.jsp

Hope you got it sorted?
Thanks for the offer, but I failed to even read the title!... lol

Just in case you are still wondering, or for anybody else that finds this question:

You can use ethtool to set different variables on an NIC card from the command line, something like this:
ethtool -s eth0 speed 10 duplex full autoneg off
but this change is lost as soon as you deactivate the NIC card, or reboot.
The *proper* way to make this change "permanent" is by editing the ethtool configuration file.
To do what you want to do, you could try this:

#
# File: /etc/sysconfig/network-scripts/ifcfg-eth0
#
DEVICE=eth0
IPADDR=192.168.1.100
NETMASK=255.255.255.0
BOOTPROTO=static
ONBOOT=yes
ETHTOOL_OPTS="speed 10 duplex full autoneg off"

The *newbie* way to make something happen at every startup is to add this command in your /etc/rc.local file which is run at the end of every reboot:
ethtool -s eth0 speed 10 duplex full autoneg off

Hope this helps

~cheesygit182
0
 
LVL 4

Expert Comment

by:cheesygit182
ID: 18927755
ty :)
0
 

Author Comment

by:mhorrocks
ID: 18930884
A very informative answer.  Thank you for being clear and concise about the solution.  Your answer should help out others who are learning by doing.

Again, thank you!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guacamole cut and paste issue 3 95
dot directory in FreeBSD??? 4 87
mobaxterm not able to change directory 28 207
SUSE Linux Enterprise 11.x Ensure tftp server is not enabled 1 44
This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question