Mailbox Database exceeded 50GB and stopped my e-mail services Exchange 2007

What is the proper way to increase the mailbox database.  I got an error in the event log last night and it said "The logical size of the database (the logical size equals the physical size of the edb file minus the logical free space) is 50 GB.  This database size has exceeded the size limit of 50 GB.      source is MSExchangeIS Mailbox   Event id 9390.    I am running on Exchange 2007.
patrickmillerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

patrickmillerAuthor Commented:
Sorry, The Event id was 9690
0
NJComputerNetworksCommented:
0
NJComputerNetworksCommented:
Exchange Server 2007 comes in two flavors, a standard edition and an enterprise edition, just like previous versions of Exchange. The Mailbox Server when talking about the Exchange Server 2007 Standard edition supports a total of 5 Storage Groups and 5 databases. Unlike Exchange 2003 and previous versions of Exchange there’s no longer a database storage limit in the standard edition. The Mailbox server in the Exchange 2007 Enterprise edition supports up to 50 Storage groups and a maximum of 50 databases per server. Exchange 2007 allows you to create up to 5 databases in each Storage Group as is the case with Exchange 2003, but best practice is to create 1 database per Storage Group. So why should you have a one to one relationship between storage groups and databases? Well primarily because you’ll be up and running a lot faster considering disaster recovery scenarios, etc.

http://www.msexchange.org/tutorials/Exchange-2007-Store-Related-Changes-Improvements.html

So, my previous post was talking about Exchagne 2003...

hmmm...
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

NJComputerNetworksCommented:
0
patrickmillerAuthor Commented:
Yes,  We just installed it two weeks ago and that is what was shipped to us.
0
patrickmillerAuthor Commented:
so are you sure that the regedit entry for the "Database Size Limit in GB" (that doesn't exist now) is the way to change the limits on Exchange 2007?
0
NJComputerNetworksCommented:
No, sorry, I am not sure... I'm not using Exchang 2007.  Hold off until someone else confirms...
0
SembeeCommented:
While Standard edition of Exchange 2007 has an unlimited database size, the database is limited by the registry key to 50gb out of the box. You need to change the registry key to increase the limit. It is designed as a safety feature.

Simon.
0
patrickmillerAuthor Commented:
So do I use the same registry entry as for Exchange 2003
0
rakeshmiglaniCommented:
0
SembeeCommented:
I shall be a little lazy here and point you to the Technet article that explains the key and what has happened.
http://technet.microsoft.com/en-us/library/bb218316.aspx

Simon.
0
patrickmillerAuthor Commented:
"Database Size Limit in GB" or just "Database Size Limit"  is what I set the registry entry as.
0
rakeshmiglaniCommented:
Database Size Limit in GB
0
SembeeCommented:
The registry entry name is

Database Size Limit

The value is the size in gb - so 50 would be 50gb.

Simon.
0
NJComputerNetworksCommented:
I would agree with "Database Size Limit in GB"

0
NJComputerNetworksCommented:
...because its the same value that you would add as in Exchange 2003:  http://msexchangeteam.com/archive/2005/09/14/410821.aspx
0
patrickmillerAuthor Commented:
http://technet.microsoft.com/en-us/library/bb232092.aspx

This article shows just "Database Size Limit"  so I a little puzzled about which one to use.
0
NJComputerNetworksCommented:
http://technet.microsoft.com/en-us/library/bb232092.aspx   <-- this link is pretty clear, I would use "database size limit"
0
SembeeCommented:
I have just tested this.

This is the correct DWORD Value:
"Database Size Limit in GB"

Set the number in Decimal, not Hex.

I have Microsoft looking in to the discrepancy at the moment.

After making the change, restart the Information Store service. You will then get an entry in the Application event viewer of the server, event 1216 that says something like

"The Exchange store 'First Storage Group\Mailbox Database' is limited to 75 GB. The current physical size of this database (the .edb file) is 14 GB. If the physical size of this database minus its logical free space exceeds the limit of 75 GB, the database will be dismounted on a regular basis. "

That indicates you have the registry key correct.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.