Windows Security Warning blocking .asp files

I'm running Vista Home Premium.  A client has sent me a .zip file as an attachment to an email.  I have downloaded the .zip file to my desktop.  This .zip file contains a few .asp files which Windows aparantly sees as being a threat to the system - I assure you the files are clean.

When I attempt to "un-zip" the file, I am getting a "Windows Security Warning" pop-up that reads "Windows found that this file is potentially harmful.  To help protect your computer, Windows has blocked access to this file."

I need to be able to access these files that Windows sees as a threat.  Any ideas?
dpalmer2343Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam LeinssServer SpecialistCommented:
You usually get this message if you try downloading risky files within an Internet zone from the Internet.  Try this: save the attachment onto your C: drive.  From Windows Explorer, drill to the file and then try opening it.  Does it open?
0
dpalmer2343Author Commented:
I can access and open the .zip file just fine to view the list of the files included in the archive.  The problem occurs when I try to extract the files from the archive either all at once or one by one.  This appears to be an issue with the built-in .zip file handling of the Vista OS.  

I tried to extract the files using WinRAR and it worked like a charm. No security alerts or blocking occurred.

I understand why Microsoft would implement blocking the extraction of potentially dangerous files from an archive, but there should be a way to allow the extraction after being warned.  Can anyone tell me if this is possible with the built-in .zip file handling in Vista, or am I going to have to stick with a 3rd party tool like WinRAR?
0
jafawcettCommented:
If you can view the files in the zip folder, but just cant unzip the file try this.  Open the zip file and just do a sinple copy and paste of all the files in the the zip to another folder.   This should bypass the security protocals.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Adam LeinssServer SpecialistCommented:
Sorry, I re-read your question and you did save it outside of your e-mail program.  This article, although written for Windows XP SP2, closely describes your problem: http://support.microsoft.com/?kbid=883260.

Part of the article:
"...if you save a compressed file (.zip) that is attached to an e-mail message to your hard disk, the Web content zone information is also saved when you save the compressed file. When you try to extract the contents from the compressed file, or if you try to run a file, you cannot. The Web content zone information is saved together with the files only if the hard disk uses the NTFS file system."

So, the quick fix is to use a freeware ZIP solution, such as ZipCentral if you state that WinRAR works fine.  The long fix is to run "gpedit.msc" from the run command, go to User Configuration\Administrative Templates\Windows Components\Attachment Manager and set "Do not preserve zone information in file attachments"

Interestingly enough, Winzip "honors" the wishes of the Attachment Manager: http://www.winzip.com/es/soft/xattmgr.htm.  If you were to try Winzip instead of Winrar you would have gotten the same message.
0
dpalmer2343Author Commented:
jafawcett:  No go.  I still get the windows security warning message when copying and pasting any of the .asp files.
0
dpalmer2343Author Commented:
aleinss:  I'm running Home Premium so I don't have "gpedit.msc" as an option.  Any Idea as to which registry key(s) to modify to make the change to the attachment manager?
0
Adam LeinssServer SpecialistCommented:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments      

Make a key under this branch called:

SaveZoneInformation      

Set the DWORD value of this key to 2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Adam LeinssServer SpecialistCommented:
Also, since this saves the zone information in the NTFS stream of the file, you will likely have to delete and re-download the file before you see results.  I would also reboot after making the registry change.

And....since this is set in HKCU, the change will only take place for your user profile.
0
dpalmer2343Author Commented:
aleinss:  I don't have anything deeper than HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

No "Attachments" branch in Home Premium I guess.  Oh well.  I was hoping this would be an easy setting to change, but if it is going to require a deep reg edit, I will just use a 3rd party archive tool.  The Points are yours.  Big thanks to Microsoft for a VERY user friendly new OS. :(

Thanks to everyone for their input.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.