Solved

The system DLL user32.dll was relocated in memory

Posted on 2007-04-05
18
6,051 Views
Last Modified: 2009-05-20
I got an error while trying to install a program (Nokia LifeBlog 2.5.224 - http://r2.nokia.com/nokia/0,,71739,00.html):

"The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\WINDOWS\system32\SHELL32.dll occupied an address range reserved for Windows system DLLs. THe vendor supplying the DLL should be contacted for a new DLL."

Someone know how to fix it?
0
Comment
Question by:rulirahmadi
  • 10
  • 2
  • 2
  • +2
18 Comments
 
LVL 59

Expert Comment

by:LeeTutor
Comment Utility
I think your answer is this hotfix recently put out by MS:

http://support.microsoft.com/default.aspx?scid=kb;en-us;935448
The Realtek HD Audio Control Panel may not start, and you receive an error message when you start the computer: "Illegal System DLL Relocation"
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
I've read that, but my sound card is Conexant. Also, your link is about "Hhctrl.ocx" and not "shell32.dll". But could be the same way to fix my error?
0
 
LVL 59

Expert Comment

by:LeeTutor
Comment Utility
Well, I'm not sure.  This problem has recently appeared a number of times at E-E, and references user32.dll and sometimes Rthdcpl.exe.  It MAY be the same problem, just not recognized as such yet by MS.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
I've just had a similar problem with a customer's PC which was caused by the last windowsupdate (nothing to do with either nokia or realtek). I ununinstalled that update and it was OK. To uninstall such updates go to \windows and look for the hidden $NTUnin.... directories, and inside those with the newest dates look for the file user32.dll. If you can find it run the spuninst.exe file to uninstall that update.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
@Lee,
Your link did not solved my problem.
The auto run of Norton Ghost 10 bootable CD got the same error too.

Oh yes, after installing the HotFix, I noticed on my SysTray new WindowsUpdates (automatic updates) and it's not installed (not sucessfull installed):
Definition Update for Windows Defender - KB915597 (Definition 1.17.2437.5).

@Rindi,
I found one file (user32.dll) inside the $NTUnin... directory: C:\WINDOWS\$NtUninstallKB925902$. But, the date of the file quite an old date: 3/3/2005.

And, if I run the spuninst.exe, I got a warning about:

"Windows Driver Package - Nokia Modem (02/15/2007 3.1)
  Wndows Driver Package - Nokia (WUDFRd) WPD (03/19/2007 6.83.31.1)
  Hijack This 1.99.1
  Hotfix for Windows XP (KB935448)"

That above programs will not run properly.

I think I know what causeing the problem. It appears after upgrading of Nokia PC Suite. There's a new version of Nokia PC Suite available and I just upgrade it without uninstall the old version 1st.

Hm, I'm gonna try uninstall the PC Suite 1st, run its cleaner program, install the latest version.

I'll keep u all posted.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
Just restoring a backup (created one month ago). Everything is fine now.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
No, my problem did not solved :(
I really afraid now because I can't install any programs (maybe a big program) if I received the error again.

The backup did not solved my problem. After restoring the backup, I try to install a new program and then the error come back again.

Finally, I booted my PC (laptop) using its recovery CD (came with the box) and delete everything (partition, data, overwrite all sectors). It tooks 5h to finished the job (5h just for deleting).

I'm still afraid for installing a new program right now.

Please, If someone know how to fix it or what makes the error come to my pc, do let me know.

@Admin/Mods,
give me a week before closed/deleted this question.

Regards,

Ruli Rahmadi.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
@rindi,
just trying your way and it work but quickly I noticed "New updates and ready to install" in my SysTray. I installed that update then restart Windows.

The problem come back again. I think this is the same update that I removed before.

My Automatic Updates is set to: "Download updates for me, but let me choose when to install them".

Is there a way around that I can prevents WindowsUpdates to download this update?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 87

Expert Comment

by:rindi
Comment Utility
If you know which update it is, you can try updating via the windowsupdate site, and there you can remove unwanted updates from the list. You should also be able to remove unwanted updates via the automatic updates option. You should get a yellow shield in the taskbar when updates are available, and when you click on that a window should open where you can select express or custom. Use custom, and when the available updates are listed, you can deselect the one you don't want, and there should also be an option to remove it from the list.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
The shell32.dll that I found on $NTUnin... dir, exactly same with http://support.microsoft.com/default.aspx/kb/935448/en-us (The security update 925902). I've installed the hotfix, but the problem still occured.

I'm gonna try your way right now.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
Oh yes, almost forgot, is there a way that we can prevents the error without removing the "user32.dll"? I can't found it on Microsfot website (their MSDN or newsgroups) :(
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
@rindi,
I removed the KB925902 with a warning that KB929338 will not work properly. But, after that, I can't open the Advanced Settings of my Bluetooth (BT) (WIDCOMM). I right clicked the BT icon on SysTray then choose Advanced Settings. I received something about user32.dll or shell32.dll (I'm not so sure).

I'm also posted the same question in http://www.microsoft.com/windowsxp/expertzone/newsgroups. Someone told me that the error because of I've Bricko Pack Vista Inspirat installed but other people can fix his problem with just installing the hotfix. Only one problem he got that his computer can't restart anymore after installing the hotfix.

I'm restoring the same backup again on my Windows and now I'll disable the KB925902 and KB929338.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
Hey, I formatted my HD again (deleted all partition and start everything from zero). I received the update 925902 (MS07-017) and security update 928843 (MS07-008) as http://support.microsoft.com/default.aspx?scid=kb;en-us;935448 said: "This problem may occur after you install security update 925902 (MS07-017) and security update 928843 (MS07-008)".

But I'm not trying to install the Bricko Pack Vista Inspirat. When I click the setup program of Nokia LifeBlog, the setup run smoothly now without error.
0
 
LVL 5

Author Comment

by:rulirahmadi
Comment Utility
I found the answer for my question by my self:

It's because of I've BricoPack Vista Inspirat installed on my Windows XP.
See http://www.crystalxp.net/news/en170-BricoPacks-and-Windows-Updates-Crashes.html and http://forum.crystalxp.net/index.php?showtopic=18560&st=0 for more info.

A request for refound and close has been posted in the Community Support area.
0
 
LVL 1

Accepted Solution

by:
kodiakbear earned 0 total points
Comment Utility
Closed, 500 points refunded.
kb
Experts Exchange Moderator
0
 

Expert Comment

by:krawl23
Comment Utility
1. Uninstall windows hotfix KB925902
2. Go to automatic updates in control panel,check notify me but don't automatically download or install them
3. when there are updates, you will get a popup notifying you, click on it and go to manual
DO NOT reinstall this KB925902 hotfix, uncheck it and check the box "never notify me about this update again" in the following window.

gabriel altamirano

0

Featured Post

Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

Join & Write a Comment

Suggested Solutions

If your system is showing symptoms of browser hijacks or 'google search redirects' check out my other article (http://rdsrc.us/u3GP7A) first and run the tool TDSSKiller (http://rdsrc.us/GDBBs4) to get rid of the infection. Once done, and if the …
It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now