Error installing dotnetfx

Posted on 2007-04-05
Last Modified: 2013-11-13
Installing dotnetfx.exe  get an error that it can not find tmp31.tmp.  Any ideas?
Question by:drmarston
  • 3
  • 3
LVL 25

Expert Comment

ID: 18858995
Are you an admin when you run the install?

It sounds like dotnetfx, unpacks things and one of the temporary files can't be located after unpacking.  Could be a number of things.  One thing could be that it gets placed in a bad sector on the hard drive..  If you aren't running as an admin this could cause all sorts of problems also.

Just some thoughts.

If you really want to see exactly what's going on go to and download the Filemon.exe.  Log in as Admin, run Filemon.exe, filter out anything you don't care about and be sure to be in capture mode, then run dotnetfx.exe.  When it fails, stop capturing in Filemon and then look through everything. If you see Access Denied or other errors, they may help you determine the cause of the problem.



Author Comment

ID: 18859101
Thanks for the quick response.  I got the local administrator part covered.

Accepted Solution

drmarston earned 0 total points
ID: 18875574
After fighting a downward spiral (Install hung.. could'nt re-install, couldn't un-install) I manually removed .net, then re-installed..
MS KB# 320112
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

LVL 25

Expert Comment

ID: 18875741
ok. Did that fix it?

It does happen.

Author Comment

ID: 18875835
Yup, that fixed it
LVL 25

Expert Comment

ID: 18876445
Glad it works now!

The unwritten rule for Microsoft software is:

No matter how absurd the idea sounds, one of the following three things often(but not always) fixes the problem no matter what it is:

1.)  Reboot
2.)  Reinstall
3.)  Restart (process)

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
factory reset 9 64
laptop problem 21 96
How to open a .vcf file 11 53
WIndows 10 tablet mode on screen keyboard split mode 7 28
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now