Security warning Unsafe expressions are not blocked

How do I get this message? This comes up when I first open Access.

Thanks
LVL 34
Mike EghtebasDatabase and Application DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mbizupCommented:
Mike,
It sounds like you just started using A2K3?

If you set the macro security level to low (not recommended) you can get rid of it.  Otherwise you can
- Deal with clicking throught the warnings
- Digitally sign your project
...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
Because the sandbox mode is set to LOW ...

Check this link ...

http://www.experts-exchange.com/Microsoft/Development/MS_Access/Access_Coding-Macros/Q_22468746.html

mx
0
mbizupCommented:
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
To minimize issues ... leave the setting Low.  Med and High are a false sense of security in A2003.

I know mbiz and I do not agree on that, so I guess we agree not to agree :-)

mx
0
mbizupCommented:
LOL!  I'm not totally disagreable ......
My issue with that (especially on a public forum) is that many workplaces, including the US Govt. (I'm pretty sure this is globally enforced now) consider the low setting in violation of security policies.

Regardless of the sense of it.
0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
L  O   L ....

Well ... I agree with that then ...
Interesting that here at So Cal Edison ... Low is not enforced (yet) on the few systems that have O/A2003.  Most users however are on Office/Access XP.

Seems all these Sandbox issues are suddenly coming up ... weird.  I think I will stick with my two large cat litter boxes and my four indoor cats ... no major issues there, lol.

mx
0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
ok ... mbiz ... I have a suggestion re "level to low (not recommended) you can get rid of it."

Maybe you could insert ("not recommended by FDA, FCC, CIA, FBI and other Gov't institutions") ... that would clarify it ... what do you think?  Then ... I wouldn't feel compelled to always counter that, lol ...

yes/no ?

mx
0
mbizupCommented:
How about:

Level to low -- Possibly Not recommended (** check into your company/organization's security policy)

** Footnote:  Added to keep mx in check

:-)
0
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
You get these messages because, as others have said, your macro security is set to Medium or higher. You can set to Low and remove the warnings, as others have said, but that could potentially leave your machine open to attacks (not highly likely, but the threat is still there).

MX has provided some good links to helping you understand why this occurs, and what to do about it, but I'll summarize.

It's a little more involved that just signing your code. To remove the warnings you would (a) insure that your machine is using the Jet 4.0 Service Pack 8 for you particular OS, (b) enable Sandbox mode, (c) purchase (or make) a certificate and install it on your machine, (d) digitally sign your application  and (e) choose the correct answers the next time your app opens. If you do these things, then your application will not display the security warnings again.

If you plan on deploying this to others, then you'll probably need to purchase a commercial certifcate (like from www.instantssl.com or some other trust authority). You'd use this cert to sign your project, then deploy it to others. When others attempt to open your file, they'll get a prompt to accept and install your certificate; after they do this, then they'll be able to open your file without warnings IF they already have Sandbox mode enabled. If not, then nothing you do will stop the security warnings.

Again, the link that MX provided will go into much greater detail, but perhaps this will help.

0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
mbiz.  Excellent. Make it happen.  'check' mate :-)

mx
0
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
On my laptop, I can change the security level to low, but cannot at the companies computer. Need to talk to IT manager.

Thank you all.
0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
You're welcome ...

mx
0
mbizupCommented:
Glad to help
0
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Systems AnalystCommented:
Guess we can all agree this was win-win-win-win (aka win4x) :-)

mx
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.