Solved

Cisco Pix 501 PPTP VPN not working properly

Posted on 2007-04-05
9
502 Views
Last Modified: 2008-10-15
Hello all.

We recently set up a Cisco Pix 501 on our network as the router/firewall.

I have set up a Cisco VPN (with the PDM VPN wizard).  That works well.  With the Cisco VPN Client users can access all inside resources.

I have also tried to set up a PPTP VPN so users can connect without the Cisco client.  I can sucessfully connect to the Pix with PPTP remotely, but can't access any inside resources or ping inside resources.  What am I missing?  Probably an access list entry?
Thanks for any help.

-benab

Here is my config:  (private info is taken out)

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password **HIDDEN** encrypted
passwd **HIDDEN** encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inbound permit icmp any any echo-reply
access-list inbound permit tcp any host **outsideIP** eq smtp
access-list inbound permit tcp any host **outsideIP** eq https
access-list staff_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.1.96 255.255.255.240
access-list inside_outbound_nat0_acl permit ip any 192.168.1.96 255.255.255.240
access-list inside_outbound_nat0_acl permit ip any 192.168.2.0 255.255.255.240
access-list inside_outbound_nat0_acl permit ip any 192.168.1.96 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.96 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside **outsideIP** 255.255.255.252
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool mcpool 192.168.1.100-192.168.1.110
ip local pool pptp 192.168.1.111-192.168.1.121 mask 255.255.255.0
pdm location 192.168.1.5 255.255.255.255 inside
pdm location 192.168.2.0 255.255.255.240 outside
pdm location 192.168.1.96 255.255.255.224 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp **outsideIP** smtp 192.168.1.5 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp **outsideIP** https 192.168.1.5 https netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 **outsidegateway** 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup staff address-pool mcpool
vpngroup staff dns-server 192.168.1.2
vpngroup staff default-domain **domain**.local
vpngroup staff split-tunnel staff_splitTunnelAcl
vpngroup staff idle-time 1800
vpngroup staff password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local pptp
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username **HIDDEN** password *********
vpdn username **HIDDEN** password *********
vpdn enable outside
dhcpd address 192.168.1.11-192.168.1.20 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:51d2a1570d907ff0bef9920d4431f66e
: end
[OK]
0
Comment
Question by:benab
  • 5
  • 3
9 Comments
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 18861397
Try to add "fixup protocol pptp 1723" in the config.
0
 
LVL 1

Author Comment

by:benab
ID: 18863401
Hmm... I will give that a try and let you know.    
Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18867231
From a PPTP client while connected but can't access anything, post result of C:\>route print
0
 
LVL 1

Author Comment

by:benab
ID: 18867595
This is after I connected to the PPTP VPN.

Interface List
0x1 ........................... MS TCP Loopback interface
0x5 ...00 0c 76 4e 4a 68 ...... MSI/Broadcom 440x 10/100 Integrated Controller -
 Packet Scheduler Miniport
0x180007 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.3.1    192.168.3.10       20
    69.48.111.130  255.255.255.255      192.168.3.1    192.168.3.10       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0    192.168.1.111   192.168.1.111       1
    192.168.1.111  255.255.255.255        127.0.0.1       127.0.0.1       50
    192.168.1.255  255.255.255.255    192.168.1.111   192.168.1.111       50
      192.168.3.0    255.255.255.0     192.168.3.10    192.168.3.10       20
     192.168.3.10  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.3.255  255.255.255.255     192.168.3.10    192.168.3.10       20
        224.0.0.0        240.0.0.0    192.168.1.111   192.168.1.111       50
        224.0.0.0        240.0.0.0     192.168.3.10    192.168.3.10       20
  255.255.255.255  255.255.255.255    192.168.1.111   192.168.1.111       1
  255.255.255.255  255.255.255.255     192.168.3.10    192.168.3.10       1
Default Gateway:       192.168.3.1
===========================================================================
Persistent Routes:
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 79

Expert Comment

by:lrmoore
ID: 18867758
This looks like it "should" be working. We can verify that your local lan is not the same as the subnet inside the pix, and that the correct route entries and subnet are there.
I don't see anything wrong with the PIX config..
Try ticking "Use default gateway on remote network" in your MS dialer properties and see if that makes a difference. It should not.
Just for reference:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080093f89.shtml
0
 
LVL 1

Author Comment

by:benab
ID: 18869575
the subnet inside the PIX is 192.168.1.0/24
the subnet where I am connecting from is 192.168.3.0/24

I tried this from a second computer (PC2) and it also did not work.
I then tried the suggestion from lrmoore to use the default gateway of the remote network on the original PC that I tried this from (PC1) and it now works on that PC1!  It does not work the on PC2 even though both of them have the default gateway of the remote network.

They are both configured the same way connecting from the same network and get different results! This is very weird.

It appears that names cannot be resolved while connected to the VPN, also Internet access is unavailable while connected to the VPN.  For these reasons I think it might be best to stick with the Cisco VPN unless there are some quick fixes for that.  

Thanks much
0
 
LVL 1

Author Comment

by:benab
ID: 18914707
Well I did add "fixup protocol pptp 1723" to the config and it still looks like there are problems accessing resources inside.  Any other thoughts?

thanks
-Ben
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18914911
>It appears that names cannot be resolved while connected to the VPN,
This is a DNS issue. Add something like this for internal dns server:
vpdn group client configuration dns a.b.c.d a.b.c.e

>also Internet access is unavailable while connected to the VPN.
You would have to un-tick "use default gateway on remote network"

>I think it might be best to stick with the Cisco VPN
Agree 100%. It is easier to manage and much more secure.
0
 
LVL 1

Accepted Solution

by:
benab earned 0 total points
ID: 22692591
Well, sorry for not finishing this post earlier.  We decided to work around the issue by not using PPTP.  Thanks for your efforts!

-Ben
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

709 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now