RPC error in ISA 2004

While i am trying to add windows domain users to the ISA 2004 Server user group,it is showing RPC

Two things i tried without success

1, Created a rule to allow RPC.
2, Tried to disable the RPC filter.

Any one having any suggetion please help?
ShibintAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LimeSMJCommented:
Can you be a bit more specific with the error?  Are you running Standard or Enterprise?

For now, if you didn't already, you may want to try this Microsoft ISA Standard RPC patch to see if it fixes your problem:

http://www.microsoft.com/downloads/details.aspx?FamilyID=0b3b8b50-9a7a-43ca-8e30-ccfcd8ad5fa3&DisplayLang=en

By the way, next time you might want to post firewall questions in the Firewall section and not in Windows Networking (you may get help faster).
0
LimeSMJCommented:
Nevermind the last line...
0
drtoto82Commented:
can't really understand what u want to say .
Do u want to manage ISA using RPC ? or u can't add users or what ?

Any way make sure u enable TCP port 135 for the RPC connection . Also , make sure of making proper source and destination and remember that ISA treats the local host (the ISA server itself) as a separate netwrok .
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Keith AlabasterEnterprise ArchitectCommented:
Firstly, don't disable the rpc filter; without you are dead in the water. The RPC filter is responsible for controlling all of the dynamic aspects to the RPC controls so if you turn it off, YOU will need to create all the controls necessary manually.

Confirm you have ISA sp2 and the post ISA sp2 rollup patches installed.
Is ISA installed as a proxy or as a firewall? Is ISA part of the domain?
What rule(s) have you put in place on the ISA firewall policy to allow traffic between the internal network and the local host (and back)?

Keith
ISA MCT
0
ShibintAuthor Commented:
Can Any one give me a exact configuration required to configure a ISA server on a domain envirnment as a proxy & firewall.?

What you meant by create the all controls?

The problem i cannot add users?
0
Keith AlabasterEnterprise ArchitectCommented:
No-one would be that stupid. You haven't told us what you want to do so how could anyone give you an exact configuration?

You tell me what you want to allow in from the Intenet
Tell me what you want to allow out from the inside to the Internet

I still need to know what revision of ISA2004 you are running. If you won't answer the responses, there is not much we can do is there.

What rule have put from internal & local host TO internal & local host?
0
ShibintAuthor Commented:
I tried to allow all protocols from  internal & local host TO internal & local host.

Specifically i want to allow http,https, ftp,smtp,pop3 & pptp.
0
Keith AlabasterEnterprise ArchitectCommented:
Assuming you have set ISA up correctly in the first place with the correct ip addresses in the klocal address table etc then i would run the best practice analyser. This will tell you if you have a fundamental issue as no amendments should be required on the RPC filter at all.

http://www.microsoft.com/downloads/details.aspx?FamilyID=D22EC2B9-4CD3-4BB6-91EC-0829E5F84063&displaylang=en
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wdigitechCommented:
I had the same issue and this I fixed it:
1. Open the ISA Management Console.
2. Right Click on Firewall Policy and select Edit System Policy.
3. Under the option for Authentication Services you will see Active Directory. Click on it.
4. On the right side uncheck a box that says "Enforce strict RPC compliance". This is the one I found on my own.
5. Then left click on Firewall Policy and on the right side you will see the SBS Protected Network Access Rule (number 4). Right click on it and select configure RPC protocol. Then uncheck the box that says "Enforce strict RPC compliance" as above.
6. Then on the left side, under Configuration select Add-ins. On the right side, right click on "RPC Filter" and select properties. Uncheck the box that says 'enable'.
 
Restart the server and you are good to go. Microsoft had an article on this problem but when I went to it, it could not be found. He did not know what happened to it. The KB number would be 928580. Supposedly, it deals with this same issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Forefront ISA Server

From novice to tech pro — start learning today.