Solved

how to prevent folders copied to new share from becoming read only

Posted on 2007-04-05
14
211 Views
Last Modified: 2010-04-18
New Windows 2003 server was set up as file, AD and DNS server.  Includes some shares that were taking the place of of a 2000 server.  When the files were copied over to the new shares, I was getting reports of "read only" status of files.  I looked at the share and everyone had full access.  After scratching my head for a while, I noticed that the properties of all the folders I copied over was a shaded read only!  I have to unchedk read only on EVERY folder, one by one, because if I select multiple folders, the read only box is unchecked!  This is a pretty big deal, as I will eventually have a thousand or so folders to uncheck, one by one...  HELP
0
Comment
Question by:mchad65
  • 7
  • 7
14 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 18860676
It's a bogus property on folders - nothing to worry about...
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18860688
http://support.microsoft.com/kb/326549 details this: " the Read-only attribute for a folder is typically ignored by Windows"

You might also check:
http://support.microsoft.com/kb/256614
0
 

Author Comment

by:mchad65
ID: 18860706
Well, that is not true, at least in my case.  If you open a file, it opens as read only.  You can not overwrite it.  If you check the individual properties of the file, it is not read only....  No one can overwrite any of the files I copied over.
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 67

Expert Comment

by:sirbounty
ID: 18860718
Okay - well then it's the default W2k3 sharing problem. ;^)

By default, shares under W2k are Everyone/Full Control
Under W2k3 - they're Everyon/Read-Only
Change the 'sharing' permissions to Everyone/Full Control and you should be all set..
0
 

Author Comment

by:mchad65
ID: 18860731
That's the first thing I looked at.  Everyone has full control...  Still read only.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18860743
Everyone has full on the share?  Or are you looking at security?

What does this produce?

Cacls \\server\share > c:\shareacl.txt
(post the txt file created)
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18860747
How are you transferring the data over to the w2k3 server?
0
 

Author Comment

by:mchad65
ID: 18860757
I am looking at the share.  It just got worse.  I had a user open word, and save a file to the share, which saved fine.  Same user still can't open other files w/o being read only.  So it seems to be a file attribute issue...
0
 

Author Comment

by:mchad65
ID: 18860762
To answer your question, on the new server, I mapped a drive to the old server, highlighted and copied folders to the new share.
0
 

Author Comment

by:mchad65
ID: 18860782
when I run Cacls \\pcd\users > c:\shareacl.txt  I get network path not found...
0
 
LVL 67

Accepted Solution

by:
sirbounty earned 500 total points
ID: 18860811
Hmm...
I would suggest using robocopy to transfer your data (http://www.microsoft.com/downloads/details.aspx?FamilyID=9d467a69-57ff-4ae7-96ee-b18c4790cffd&DisplayLang=en)
This free tool from MS has the ability to transfer the security, timestamp, attributes, etc for the file transfer.
For instance, this would perform a server to server copy:

robocopy \\server1\share \\server2\share /mir /copyall /zb

*.* is assumed (all files)
/mir (mirror data - same as copying recursively - removing what's no longer in the source)
/copyall (equivalent to copy:datso (data, attributes, time stamps, security...)
/zb restartable/backup mode (for attempts to copy open files).

This is the preferred method for migrating data - as with NTFS, presumably what you're using for file system on your servers, data moved the way you did it inherits the target security...
0
 

Author Comment

by:mchad65
ID: 18860856
I figured it out.  It seemed to be a setting under the "security" tab of the drive.  I had to add the full control options to the "domain\users" object.  Once I did that, it worked.  Very strange.
0
 

Author Comment

by:mchad65
ID: 18860864
But thanks for the info on robocopy, that will come in handy...
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18860868
Glad you got it sorted. :^)
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question