Solved

DC Promo Error

Posted on 2007-04-05
15
1,147 Views
Last Modified: 2008-02-01
I want to perform a DC promo on widows 2003 member server.  THis is a brand new network setup... no servers, no workstations and I get this error whiler performing DCpromo

File Replication Service:

The dependency service does not exist or has been marked for deltion
0
Comment
Question by:mantic1
  • 6
  • 3
  • 3
  • +3
15 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18860893
     Hi mantic1
              *Make sure you did not check "This server is the last dc on forest" if is a member server and there are other servers.
              *Also try forcing demotion. Following article will guide you.
http://support.microsoft.com/?id=332199
0
 

Author Comment

by:mantic1
ID: 18861108
Thanks for the assistance but it was never a DC.   It's a fresh new os install and it's already giving me problems.  Also, I selected new forest/domain
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18861119
So this is the first DC for the domain?  Any other sites?  Other sites within the forest?
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:mantic1
ID: 18861261
Correct.  First DC in the domain.  1st Forest.  1st everything.
0
 
LVL 70

Expert Comment

by:KCTS
ID: 18861555
Check that the network card is enabled/connected and that TCP/IP has been installed.
0
 

Author Comment

by:mantic1
ID: 18861611
NIC enabled.  TCP/IP installed
0
 
LVL 26

Expert Comment

by:MidnightOne
ID: 18861756
Is this already configured as a DNS Server?
0
 

Author Comment

by:mantic1
ID: 18861761
Nope  No DNS was previously installed
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18861775
Since this is the first DC for everything you need something to run DNS.  Install DNS on the server and dcpromo it again.
0
 

Author Comment

by:mantic1
ID: 18861782
I thought it automatically adds DNS during promo?  Ill go ahead and add it and let you know.
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18861794
I will configure DNS for you, but you need to install the component first (it will actually ask you).  Make sure you select let the wizrd setup DNS for you.
0
 
LVL 29

Accepted Solution

by:
Alan Huseyin Kayahan earned 500 total points
ID: 18862526
              Hi mantic
                    *Make sure you have the service pack installed.  
                    *Please check your eventlogs and please post the errors. Here is an example below.
Event Viewer: The net logon service depends on the following non existent service DNS
                    *Please EMPTY the preferred and alternative DNS addresses in TCP/IP properties. Dont even write 127.0.0.1. Just leave it blank, then run dcpromo. It will ask you about DNS in an earlier stage this time and CAREFULLY choose Install and configure automatically. Do not choose i will configure it later or skip service installation
                    *Now according to my example above , locate HKEY_LOCAL_MACHINE>system>currentcontrolset>services>netlogon in registry (regedit). Now in right pane, there is a value named dependonservice. Doubleclick it and remove DNS, then try dcpromo again.(This step completely rely on my example, please take this step according to your event log, also please post it here)
0
 

Expert Comment

by:nagarajnoolvi
ID: 18874529
Hi,

I think its a problem with the replication services as the problem states that its not able to recongize replication services state.  You can go to Services and check wheter the file replication service is in start/stopped/disabled state, if its disbled/stopped then you need to start the service and then proceed with the dcpromo.
Or you can diagnose the File replication service problems using Frsdiag.exe,sonar.exe or ultrasound tools provided by the microsoft, you can be able to download these from the microsoft download center.
0
 

Author Comment

by:mantic1
ID: 18878745
Wow!  It worked!!   I did not have to manually add DNS.   MrHusy is ranked Master for a reason.  I deleted the    registry file like he requested and reran dcpromo.  No problems this time around.  Thank you sir.
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18881556
     You are most welcome mantic1 :)
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question