Can't install dotnet framework 3.0

Posted on 2007-04-06
Medium Priority
Last Modified: 2010-08-05
attempting to install dotnetfx3(.Net Framework 3.0) and the following message:

Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603

I have tried everything on the framework site and nothing has worked.  including uninstalling and reinstalling IIS.  I have Microsoft Windows XP Version 2002 Service pack 2 and framework 2.0 and 1.1 installed.  
Question by:courchjo
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18863852
          Hi courchjo
                 Try installing the latest MSI installer
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18863903

Author Comment

ID: 18866409
I finally got the framework installed by creating a local admin and logging in with that ID and installing WCF.exe.  Got an error writting to key permissions problem.  Gave the key everyone priveledges and installed the WCF.exe.  Was able to install the 3.0 frame work after that.  However the System.ServiceModel doesn't show when I try to add the reference in 2005. Any ideas about that?
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

LVL 29

Accepted Solution

Alan Huseyin Kayahan earned 2000 total points
ID: 18867818
            Hi courchjo
                    I think System.ServiceModel is a Software/Programming parameter which i can not help. You asked how to install it and i redirected you and I hope it helped you (reinstalling wfc.exe). If you like, open a new question in Software/Programming zone so Programming experts will be able to see your question via their question filter.

Author Comment

ID: 18875685
I finally go installed by logging onto machine only and not network.  I installed the wcf.exe from the download folder and it gave better error messages.  That could not write to Registry and what key it couldn't write too.  I gave that key sufficient priviledges and was able to installed wcf.exe and then installed the complete framework.  Don't think this product is ready for prime time!
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18875710
 Nice to see that your problem is resolved.

Expert Comment

ID: 25536523

A quick solution may be to disable antivirus or add an exception.  I work for a large company that uses McAfee and it was the source of our 1603 error!

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Log files are useful in diagnosing and repairing problems.  This is a list of common log files and their standard locations that I've compiled.   While this is not exhaustive, it is a pretty good list that I've found to be useful.  I may update it f…
INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question