Registry edit error

Posted on 2007-04-06
Last Modified: 2008-02-01
I have a registry file that needs to be merged on a per user basis.  When i try to merge this registry file under my users login, I get a msg stating "Registry editing has been disabled by adminitrator".  there are a couple group policy's in place but i've checked every one of them to make sure the registry editing tools options was NOT configured.  These users are only a part of the domain users group which I've added w/ full control to the current users key permissions list in the registry.  The current users key is the only thing that will be modified with my registry file that I need to merge.  What am I missing that is blocking my users from merging this registry file?
Question by:blackjack2003
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 34

Accepted Solution

sramesh2k earned 125 total points
ID: 18865385
Hi blackjack2003,

>> make sure the registry editing tools options was NOT configured.

Set it to "Enabled" and click Apply. Then reset it back to "Not configured". This removes registry based policy if already set.


Alternately, you can fix this problem using the reg.exe console tool.

Registry Editing has been disabled by your administrator:
LVL 32

Expert Comment

ID: 18865444
Can't you just apply the registry fragment in a login/startup script?

Author Comment

ID: 18865522
I did select the enable option / apply and then reset it to not configured..and initially i was running it through a login and startup script(tried both)..but neither way was taking.  I'm gonna try the reg.exe method now and see how that works...will update in a bit.
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.


Author Comment

ID: 18865589
Well tried the reg entry from the link you specified but nothing changed...still same error message when I try to trun the registry file... Here is a paste of the registry file I'm tryin to input under each domain user.

Windows Registry Editor Version 5.00




"ProxyTelnetCommand"="connect %host %port\\n"
"Font"="Courier New"

LVL 66

Expert Comment

ID: 18866378
Disable Registry Editing Tools

Make sure this value is not in the registry.....

Author Comment

ID: 18875657
Found a domain group policy about 4 lvls down in the tree with the registry editing tools disabled.  Once I set this to not configured and gpupdated everything worked.

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question