Solved

two Cisco2811will loose connection  to PC(ping- t) behind Cisco2950 , will loose connection

Posted on 2007-04-06
18
547 Views
Last Modified: 2012-08-14
two Cisco2811 by FE0/0 (10.10.200.101 and 10.10.200.102) connected to Cisco2950(10.10.21.100), as well PC (10.10.10.1/15 gaetway10.10.21.100).
Behind both 2811 16port switch(VLan1 witn 10.15.200.1/28 and 10.15.200.16/28) equipment with IP -10.15.200.2 connected to one 2811 16port switch with 10.15.200.1 and 10.15.200.17 connected to one 2811 16port switch with 10.15.200.16.
When I do ping both equipment from PC, it will loose connection periodicly, and can be restored either by "repair" in WinXP or unpluged/reset one of the links to equipments(10.15.200.2 and 10.15.200.17), and bothh will be "online".
When connection is lost to 10.15.200.2/17 and I do "tracert" , instead of showing 2 hops of corrects route, it will show only one hop of the other router, where is no equipment attached.
Looks like 10.15.200.2/17  routs is not hold by 2811, or some other config/IP assigmnet problem.
Please help what is holding me here? Should I separate FE0/0 by subnetting them? Right now ther are Cisco2881#1 FE0/010.10.200.101,Cisco2881#2 FE0/010.10.200.102,Cisco2881#3 FE0/010.10.200.103,Cisco2881#4 FE0/010.10.200.104 all suppose to be connected to Cisco2950 10.10.21.100.
RIP,Ospf,IEGRP disabled and this is "stand-alone" wiring.
0
Comment
Question by:dkarpekin
  • 10
  • 8
18 Comments
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
How do you have your vlans set up? What subnet mask are you using?
If you are using /24 mask, how are you routing between the subnets?
How are you routing 10.15.200.0 to 10.10.200.0?
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
VLAN1(16 port switch) on #1 2811 10.15.200.1/28 on 2811 #2 - 10.15.200.16/28 , the are "ip unnumbered async0/0/0"
ip route 10.10.0.0 0.0.0.0 FastEthernet0/0 150
ip route 10.10.0.0 0.0.0.0 Async0/0/0 250
FE0/0 is set as "alternative" to async0/0/0, so when it is plug to LAN it will keep async down( by using150/250 delay set on IP route).
In mine emulation(before deployment), it connected to Cisco 2950(FE0/1, FE0/2+FE0/3 PC plug in).
"loosing connection problem will appear, when I plug second router into 2950, but when there is only one2811, no problem to ping fro PC to 10.15.200.2 or 10.15.200.17.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
ACTUAL CONFIG OF "FIELD1"
------------------ show running-config ------------------


Building configuration...

Current configuration : 3057 bytes
!
version 12.4
no service timestamps debug uptime
no service timestamps log uptime
no service password-encryption
!
hostname field1
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-6.T6.bin
boot-end-marker
!
logging buffered 52000 debugging
enable secret 5 <removed>
enable password <removed>
!
no aaa new-model
!
resource policy
!
clock timezone NewYork -5
clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00
!
!
ip cef
!
!
ip domain name XXXXXXXXX
!
!
voice-card 0
 no dspfarm
!
username XXXX privilege 15 secret 5 <removed>
username XXXserver password 0 <removed>
!
interface FastEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-LAN$
 ip address 10.10.200.101 255.255.255.240
 ip nat outside
 ip virtual-reassembly
 duplop enabled
!
interface FastEthernet0/1
 no ip address
 ip virtual-reassembly
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description VPG6000
 switchport mode trunk
 speed 10
!
interface FastEthernet1/1
 shutdown
- ALL SAME
!
interface FastEthernet1/14
 shutdown
!
interface F5.0
 ip nat inside
 ip virtual-reassembly
!
interface Async0/0/0
 ip unnumbered Vlan1
 ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer string 9,XXXXXXXXXX
 dialer string XXXXXXXXXX
 dialer-group 1
 async mode dedicated
 ppp authentication chap pap
 routing dynamic
!
ip route 10.10.0.0 255.255.255.240 FastEthernet0/0 150
ip route 10.10.0.0 255.255.255.240 Async0/0/0 250
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.15.200.0 0.0.0.255
access-list 189 remark permit PPTP passthrough
access-list 189 remark SDM_ACL Category=2
access-list 189 permit tcp any any eq 1723
access-list 189 permit -server community <removed> RO
!

control-plane
!

line con 0
 login local
line aux 0
line 0/0/0
 script dialer dial
 modem InOut
 transport input all
 transport output all
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 privilege level 15
 password <removed>
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 password <removed>
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
!
end


0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
>ip route 10.10.0.0 255.255.255.240 FastEthernet0/0 150
You should not point routes out a broadcast interface (ethernet), you should always use the actual next hop IP address.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
Thank you so much, I think you right
Can you also tell me , if I should do the same with ASYNC0/0/0?
This interface will start dialout as soon it will detect traffic trying going out.( if no CAT5 connected on FE0/0).
If I'll use next hop and the only one route
ip route 10.10.0.0 255.255.255.240 10.10.21.100  
Will the traffic find the way in both connection - over dialup and over FE0/0 connected to the LAN?

0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Not necessary for the async interface. You can use the interface as a gateway.
Personally, I do not use ip unnumbered and much prefer to give every interface an IP address. This allows you to keep two route statements for dial on demand routing.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
There is suppose to be 4 of  remote 2811 to be connected over dialup to server 2811, and will be no need in server2811, if LAN is available on location, and I thought simplefy config by doing "ip unnumbered", as in mine understanding it will assign to async0/0/0 same IP  10.15.200.1 and .16  and .32 and 48 of VlAN1 in "filed1"..-4" and assign async0/0/0 same ip as FE0/0 10.10.21.181 in "server".
Question is, if I'll make:
ip route 10.10.0.0 255.255.255.240 10.10.21.100 150
ip route 10.10.0.0 255.255.255.240 Async0/0/0 250
It should fix mine "posted" problem with loosing connection, but might do the same (loosing connection), when I'll be connected over dialup with "field1" and "field2" 2811. I did not tested this yet,  but I think it willhappend ( as there is the same way "point routes out a broadcast interface (ASYNC0/0/0)".

Will it be same problem over async0/0/0 in you opinion?
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Async is not a broadcast interface.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
So, that why it should not be same problem as with FE0/0 "lossing connection"?, when more than one "field1"..."4 will get connected over dial up to "server"2811 with 4 async WIC -1AM card?
Can you please tell if it will not happend, or if it will happend, what would be the possiblity by%, 70%-99%?
Thanks again for your help.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
Comment Utility
If this was setup correctly you would have a 100% possibilty of everything working the way you want it to.
I think you're going to still see some issues if FE0/0 ip address 10.10.200.101 255.255.255.240
and route
ip route 10.10.0.0 255.255.255.240 10.10.21.100 150
Your next hop - 10.10.21.100 - is not on the same subnet as your FE0 interface 10.10.200.101
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
Thank you. It was greate help.
I will assign /16 subnet to FE0/0 10.10.21.100/16 and should be all set?
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
I can't answer that because I don't know what all the other subnet masks are.
I think you have some fundamental design issues that you need to really re-think your whole layout, ip assessing scheme and routing for the entire network.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
It kind of simple, all network base on Cisco2950(total 12peaces) spreaded throught out country, with one "cetral" 2950 with IP 10.10.10.100/16, to wich is 2950 10.10.21.100/16 , as well all other connected. everything is on static IP/16, all switches is connected by "Marconi" ATM, which makes them same way as they on LAN.
"server"2811 will be behind 10.10.21.100 and provide traffic mostly to PC behind "central"2950 10.10.10.100/16.
All other switches have assigment 10.10.30/40/50/60/70/80.... .100.
Please let me know , if still have pations to review that , all otherwise I think I all set.
Thank you .
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
If all of your network has /16 mask, then certainly changing the mask on this router to /16 also will make a big difference.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
Thank you again.
I will implement those recomendation, and if you dont mind, I'll get back to you 2-3 days later.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
Makes no diffrent as was before with original subnetting.
Still loosing connection same way.
Interfaces is /16.
IP route 10.10.0.0 255.255.0.0 10.10.10.100 ( I did change 2950 switch to 10.10.10.100/16)
Now I'm thinking if I should change TTL?
I do have TTL255 to the FE0/0 and TTL63 to the 10.15.200.2 or .17 when I ping them from PC.
And I do suspecting, diffrent TTL is cousing confusion on this small network, as device expararion is shorter than Cisco.Totaly lost right now.........Cisco TAC is lost too.........
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
>IP route 10.10.0.0 255.255.0.0 10.10.10.100 ( I did change 2950 switch to 10.10.10.100/16)
You can't route it to a 2950 l2 switch.
0
 
LVL 7

Author Comment

by:dkarpekin
Comment Utility
I use to think 2950 is layer3.........but eather way , it is work same way, only diffrent is now ,that with "original' subnetting one of the 10.15.200.2  or .17 will loose connection, and will came back......now they will lose connection at same time fro approx.5-10 min, and they will came back at once................
Loosing connection is meaning of link between PC to 10.15.200.2 .17..........but PC to FE0/0's is stable as well all other "direct" connection- 10.15.200.2   .17 to the port of NM-ESW-16 module.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now