"Local Area Connection" won't stay disabled

I have a brand-new notebook with Windows XP MCE on it.  It has wireless and wired ethernet.  I'd like to disable the wired ethernet, and, indeed, Windows lets me disable it.

But...  If I reboot, or if I attach a plug-and-play device, the "Local Area Connection" magically re-enables itself!  How can I get "Local Area Connection" to STAY disabled?

I have disabled the actual Ethernet adapter in Device Manager too, but that enables itself as well.

This is insane!
LVL 1
tchrisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
Try going into network connections and disabling it.. But with the nature of plug and play it will probably reappear.. This is a feature of the operating system.. 'cause you may at one time just want to use it.. so it makes it available for you... Try looking in the bios and see if you can disable it there.. if you can it will never reappear.
0
and235100Commented:
Yes - as ve3ofa says - disabling it in the bios setup is the best idea.

But - is it such a big deal that the connection re-enables itself? Why are you trying to disable it?

If we knew that - we may be able to come up with an alternative.
0
tchrisAuthor Commented:
It's just an annoyance that the tray icon constantly pops up to tell me that a network cable is disconnected.  So, really, there are TWO bugs at work.

1.  The connection and/or network adapter won't stay disabled once it's(they're) disabled
2.  The "Notify me when this connection has limited or no connectivity" option is ignored.  (It's unchecked, but the notifications happen anyway.)

Disabling the Ethernet port in the BIOS is a viable workaround, but I'd like the Windows XP feature to work properly.  Is that too much to ask on a brand-new computer?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

and235100Commented:
Try:

Line 11
Enable/Disable Balloon Tips or >>Disable All<< (this one)
http://www.kellys-korner-xp.com/xp_tweaks.htm
0
and235100Commented:
You could also have a look at

Line 392 - Enable/Disable - Network Connection
http://www.kellys-korner-xp.com/xp_tweaks.htm

Run this .vbs as a startup or login script - then the connection would be disabled automatically
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tchrisAuthor Commented:
I'm accepting your solution, since that is a reasonable workaround.  However, it doesn't fix the root problem, so I'm giving a B rather than an A.

Thanks all for your help!
0
and235100Commented:
That's fine - no problem.

The only thing is, by definition - a "workaround" sometimes is the only "solution"!

;)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.