can't connect to remote database

Hi

I'm having trouble connecting to a mysql database remotely.

I'm accessing a mysql version 4.11 database using the query browser. For the host I am entering the ip address, and then entering the root username and password.

I get this error:

MySQL error number 1130 #HYOOOHost 'andieje.plus.com'  is not allowed to connect to this mysql server

I've looked this error up on the internet and most places say it is a permissions issue. However I'm confused because I am trying to login as 'root' but the error message says I have a host name of 'andieje.plus.com' How do i connect as root?

thanks
amdrea
andiejeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AdamRobinsonCommented:
It's actually saying your MySQL is only allowing connections from your domain, likely meaning it only allows connection from Localhost.  You'll want to check your config and make sure it's allowing connections from remote domains.

0
Steve BinkCommented:
To clarify a little bit, the server is saying that a user at host 'andieje.plus.com' is not allowed to connect.  This is a permissions problem, but you need to log to the server using an account with admin permissions.  When you say you are using a 'query browser', exactly what program are you using?

I recommend you try to login from the server's cli.  That should get you pointed in the right direction:

# mysql -u <username> -p

Otherwise, you can try a great MySQL client app:

www.sqlmanager.net
0
AdamRobinsonCommented:
routinet,

I've also seen, though I wish I had noted what version, an issue where MySQL will not allow a connection from root from outside no matter what.  This may indeed be default now, but I recall the last time I did an install (which was quite a while ago), I ran into that, and found it in the notes.  It could be he is running into this too.  Either way, your comment seems to be dead on for him.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

str_kaniCommented:
http://www.experts-exchange.com/Database/MySQL/Q_21579987.html
1)By default mysql does not support remote access...

2) you will have to specify this in the server first, (ofcourse you will not be able to do this from a remote machine!!! unless you have remote desktop access)

3)To enable access from a client machine called nile, do the following after starting mysqld (or mysqld_safe) on the server, named delaware:

% mysql -u root -p
mysql> use mysql;
mysql> grant all privileges on *.* to usrname1@'%'
identified by 'test' with grant option;
mysql> insert into host values('nile', '%', 'Y', 'Y', 'Y', 'Y', 'Y',
'Y', 'Y', 'Y', 'Y', 'Y', 'Y', 'Y');
mysql> exit


Hope this helps you!

The user name, usrname1, and the password, test, should be replaced by the real value.
One can then run mysql on nile as follows:

  % mysql --host=delaware --user=usrname1 -ptest

To restrict access to a user from a specific host, change '%' in the grant command to a valid hostname or ip address.

You can also refer this.

http://www.linuxhelp.net/guides/mysql/

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steve BinkCommented:
@AdamRobinson:  MySQL is installed by default with only specific access to the admin account, IIRC.  

str_kani has some good tips for you.  I think you could use a good guide for how to progress.  This would be an outstanding starting place for you:

http://dev.mysql.com/doc/refman/4.1/en/post-installation.html
0
andiejeAuthor Commented:
thanks a lot
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.