[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Linux box shares not accessible from windows PC. Both are wireless.

Posted on 2007-04-08
2
Medium Priority
?
221 Views
Last Modified: 2013-12-15
I am trying to setup Fedora as a file server. I cant seem to get access to the shares from a windows PC.

I have a clean build of Fedora running. Samba is setup. All the components I could find in the Yum downloader have been installed. The workgroups match. I can see the share I setup on the Fedora box from a PC laptop, but when I go to access them i get \\COMPUTER\SHARE is not accessible. I have setup the share to be r/w, visible and public. The only thing I am real curious about is the wireless thing. Both Fedora and the Laptop are running wirelessly, Does anybody have any I dea?
Thanks Jim
0
Comment
Question by:cbspectre
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 14

Accepted Solution

by:
ygoutham earned 1500 total points
ID: 18874534
are the directory permissions set right.

most often people create shares using a "root" id and end up with no access for the rest of the world.  change the ownership of the folder to a 770 with proper User.Group names defined.

check on the SELINUX part

check on the Firewall (system-config-securitylevel) part to see if samba is allowed access.

If it is only a LAN file sharing server, you might want to consider removing the above two as i do not see too much of a security threat there.
0
 

Author Comment

by:cbspectre
ID: 18875429
Thanks for the info. HEre is what I found and used to eventually solve the problem:

Run system-config-securitylevel
Firewall Options:
To allow Samba access to work through your firewall you must set 'Samba' as a 'Trusted service'.
SELinux:
Modify SELinux Policy > Samba Disable SELinux protection for smbd daemon
On the command line you can run:
[root@charon ~]# setsebool -P smbd_disable_trans 1
Run man samba_selinux for more help.
For any changes made above to the SELinux settings or smb.conf, it is recommended to restart Samba.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question