Stop local profiles being created

I have 9 Client machines and 1 server running SBS 2003 (clients all running XP). i have about 20 users who all have there own user logon's. I have set up roaming profiles (as far as i can see) but when ever a user logs onto a client machine if they havent used that one before it creates a local folder in C:\Documents and Settings the folders name is the same as their user name and contains - Application Data, Cookies, Favorites, start menu, and desktop (i thought all of this was part of the profile and in the user properties on server i have told it that the profile should be on the server in a folder called profiles and then sub folder for each user). I have also redirected start menu, desktop using a GPO, and to begin with it ised to sycronise at logoff, i made some GPO changes and that appears to of stopped but i think is still happening behind the scenes.

How do i stop local profiles being created for each user and just use the server to hold all info?
cjwdentAsked:
Who is Participating?
 
Pete LongConnect With a Mentor Technical ConsultantCommented:
Hello cjwdent,

Create group policy and enable

Computer configuration > Administrative templates > System > User Profiles > Delete Cached copies of local profiles

Regards,

PeteLong
0
 
InteraXConnect With a Mentor Commented:
Hello cjwdent,

Try this registry setting.
http://www.pctools.com/guides/registry/detail/142/

There's also a GP setting under computer configuration. You might need to create a new GPO to apply to the computers.

Regards,

InteraX
0
 
Netman66Connect With a Mentor Commented:
You can't stop this from happening - it's by design.

As Pete mentioned, you can delete the local cached copy, but why?

Windows creates the local profile for several reasons.
1)  It works from this copy during the session and copies up any changes to the network if you use Roaming Profiles.
2)  If the network became unavailable during a user's session then they continue to work properly and all changes get saved locally until the network becomes available.

If you were working live from the network profile you would have horrendous response times locally.

There is nothing wrong with your setup - it's working properly.

0
 
Brian PiercePhotographerCommented:
You can't stop profiles being created locally, When a user logs on and a roaming profile is specified Windows checks to see if the roaming profile is available, if it it then it copies it to the local PC. I fthe user changes the profile the hcnages are stored locally and sync'ed with the roaming profile on log off.

If the use has no profile (roaming or local) then the local default profile is used.

While you can't stop local profiles being copied locally you can set up a group policy that will delete the local copy after it has been sync'ed. To do the edit the default domain security policy and enable the option to 'Delete Cached Copies of roaming Profiles' under the Computer Configuration/System/Administrative Templates/System/UserProfiles option.


0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.