Laptop battery won't charge.

Unable to charge battery on Laptop after installing XP on Toughbook C-47 and Compaq Pressarioi. New battery installed  but it would not charge.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Most likely there is a loose connection or a broken wire somewhere. If you can borrow a compatible power adapter I would try that first. If that doesn't help the broken wire could be inside the laptop which would call for professional repair. Check if laptop is under warranty. Also make sure battery is seated properly.

This has nothing to do with XP being installed.
With the laptop turned off, Does the battery charging led come on when AC adapter is plugged in?
What symptoms are you seeing in XP to show its not charging. Is this an OEM battery or  replacement that isn't from the same company as the laptop manufacturer?
lquinonesAuthor Commented:
oem battery and charging light comes on but progress stops at 3-6% charged.
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Could be the charging electronics, or a faulty battery. I suppose the latter is easier to swap...
This could be a problem with the battery needing to be calibrated.
Check this link out, halfway down the page is a guide on calibrating the battery.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I know that some malfunction MotherBoards has the same result.
Had an old compaq that did exactly the same thing.
It can be bad motherboard,
I had a similar problem with a HP laptop.  I changed the battery and still no charge.  I then replaced the power cord and it worked.  So the problem may not be the battery or inside the machine.
lquinonesAuthor Commented:
the only solution that helped  was recalibtaying the  as sugggested by SPARMAKER. Battery has charged to 57% .
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.