• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 231
  • Last Modified:

User can't connect with Remote Desktop but only during certain time frame

Here are the particulars--
Windows 2003 Standard SP1
Multihomed-- &
RDP enabled on computer.
I am on same LAN as this machine and can rdp to it to my heart's content using either IP address.
User on the WAN however can not connect to using rdp.  He gets the generic RDP might not be enabled or too busy to accept connections.

Now I know everyone is thinking firewall right now, but get this.

The user only has problems from about 00:00 EST until 0400 EST.  Outside of those times he can connect without issue.  The user is actually in India.  To further muddy the waters this user can connect to other servers on the same subnet as the one he can't connect to.  Other users in the same location as this user can connect to all servers but this one.

Windows Firewall is not running on this server.  Thought maybe a scheduled task is executing to max out the NIC or something but there aren't any.  Nothing on this server is backed up, so there isn't a backup job or something maxing out the NIC either.

I created a scheduled task on another server on the same LAN to launch rdp to connect to the server using a specific user account.  A startup bat file for that user then logged off.  This ran every 10 minutes for 2-3 days and did not encounter any problems.

Nothing relevant in Event Viewer.  

The only thing I have left to do is to run Wireshark on the server to see if the client requests are reaching the server.  Can anyone think of a router/firewall problem that could be time-based?  I mean whatever is the problem is only lasting a couple of hours.

I don't think it can be anything on the user's computer because others on his LAN are experiencing the same symptoms.

Looking forward to responses.

  • 2
1 Solution
Pete LongTechnical ConsultantCommented:
Hello averyb,

Heres a longshot - on the server in question can you create this registry entry

Start > run > regedit {enter}

Navigate to >HKey Local Machine \ System \ Current Control Set \ Services \ TCPIP \ Parameters
Create the following
New DWORD : EnablePMTUBHDetect
Value : Hex, 1

And reboot the server

Any difference?.


averybAuthor Commented:
I'll need to confirm that I can reboot the server; but it should be doable.  

This problem is also intermittent.  It was reported to me about a two weeks ago.  Then it worked for a day or two. And now it's not working again.  There are also reports that this same problem happened months ago but no one knows how it was resolved or if it jus went away.

The day or two that it was working roughly coincides with the time I was running the scheduled task to launch a rdp connection to the server.  I started running the script on 4/2 and stopped it on 4/4.  The user was able to connect since 4/3, but this morning he couldn't connect again.

I tihnk I'm going to run Ethereal on the server to see what that shows me before doing the registry tweak.
Pete LongTechnical ConsultantCommented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now