Import excel spreadsheet into Sql Server schema - numbers become exponentials: Why? Fix?

I have an excel spreadsheet that I import into a table in a SQL server schema. Once I import it, all the data appears perfectly EXCEPT a column (record_num), which has 6-8 digit numbers. On the Excel sheet this column displays the numbers just fine, but once I import it into a SQL table, the data in that column looks like this : "2.12043e+006" (instead of 2120426)

Now I looked at the SQL table's design and the data type is set to "varchar: 100"

If I re-format the column in excel as general, text, or number - I still get exponentials instead of the ACTUAL 6 or 8 digit number.

What am I missing? There's over 400 rows of data.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy Hengel [angelIII / a3]Billing EngineerCommented:
can you try to add the following to the extended properties of the connection string to the excel file:

should solve the problem
super786Author Commented:
how do I do that? I use ms-excel 2005.
Guy Hengel [angelIII / a3]Billing EngineerCommented:
how do you import actually?
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

super786Author Commented:
In SQL Server, go to schema, right-click, import data, select source: excel, browse for file, append to respective table, done.
super786Author Commented:
Guy Hengel [angelIII / a3]Billing EngineerCommented:
you might consider reading my comments about such behaviour in my profile:

anyhow, is this import task to be a one-shot operation, or a task to be repeated?
in first case, you might consider using ms access with a linked table to the SQL Server table, copy the data from excel and paste into the table using the linked table in access.

if it is a task to be repeated, you should consider checking out SSIS, where you can specify some connection parameters when importing (excel) files, ie the IMEX=1 I mentionned above.
super786Author Commented:
Ok now its giving me another error. Seems as though now the record_num is working fine (I changed it to text). But the other problem I am having now is the date_column. My SQL design for the table for this column is datetime :8, as it also is on the spreadsheet. I try and import it and now it says the date_column is in incorrect format. I tried text, help. I tried saving it as csv, but still doesn't work.
Guy Hengel [angelIII / a3]Billing EngineerCommented:
in general, I highly disrecommend to load directly to production tables.
always load into a staging table first (which has only varchar columns), validate and clean the data in there, and convert from there to the true table.
will help to avoid / solve many, if not all, problems like the one with date fields.
exception is with data sources that are "sure" and fixed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MS Access - I had the problem of Social Security Number getting converted to exponential format when importing from Excell spreadsheet, even though the Excel column 'Format' was defined as 'Text' as was  the Access table field. In fact all but the SSNs starting with zero were messed up - that's why I didn't notice anything was wrong for a while, because the first few screens looked good.  I found that if I created the SSN column in Excel as 'Text' ( so I could retain leading zeros) and then changed it to 'General' before I saved it and imported to Access, that seemed to work. Hope this helps somebody.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.