Solved

Windows 2003 server assigning incorrect (old) DNS server IP via DHCP

Posted on 2007-04-09
4
540 Views
Last Modified: 2008-02-01
Small problem with a Windows 2003 server running DHCP.  I recently needed to remove one of the two Domain Controllers in this network.  The DHCP server on the remaining Domain Controller was originally configured to assign both itself and the other DC as DNS servers with the other DC as the primary DNS server.

I've reconfigured the DHCP scope, removing the old DC as the primary DNS server but about 50% of the time on boot the client PC's seem to still set it as the primary DNS server.  

I have not rebuilt the DHCP scope from scratch as there are multiple reservations and I'd prefer not to have to do this but I'm at a loss for where the client PC's are pulling the old DC as the primary DNS server from.

How can I resolve this issue?
0
Comment
Question by:winningtech
  • 2
4 Comments
 
LVL 70

Accepted Solution

by:
KCTS earned 250 total points
ID: 18876873
The clients will retain the old information until the lease is renewed, if you want to force this then run the ipconfig /renew command on the clients, they will then renew the lease and get the new DNS server info.

It might also be worth chacking that come lients have not got the DNS server assigned satatically.
Alpo check that the DNS is not being assigned differently on the reservations. (You can assign options at the server level, scope level and reservation level - make sure there are no conflicts)
0
 

Author Comment

by:winningtech
ID: 18877735
I'll doublecheck the reservations.  As far as doing the ipconfig /renew I've done this on a few PC's when they've retrieved the wrong DNS settings.  Renewing the IP address causes them to obtain the correct DNS IP address.  My issue is when the PC's are rebooted they revert to obtaining the old DNS server IP address.

I've verified that regardless of which DNS server they're getting they get it from the same DHCP server (which is also the Domain Controller and DNS server).  

Am I missing something in Group Policy or DNS on the Domain Controller which might be causing the workstations to revert to the older server for DNS?
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 18878467
Make sure that you don't have options set at both the scope and server level.  If you have both, then the scope level options will override the server options. So, if you have scope options set for the old DNS server and server options set for the new, that could be the problem.
0
 

Author Comment

by:winningtech
ID: 18884865
I think I've resolved this.  I found that the old DC still had a deauthorized DHCP scope but that the server was still authorized.  I was unable to unauthorize the server so, as I no longer need DHCP on this server, I uninstalled DHCP.  On the off chance that the problem reoccurs I also configured DNS secondary zones on this server and configured DNS replication from the DC to this server.  

Thanks for the advice.  Both answers made me wonder if there might have been another DHCP server somewhere on the network.  
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On a regular basis I get questions about slow RDP performance, RDP connection problems, strange errors and even BSOD, remote computers freezing or restarting after initiation of a remote session. In a lot of this cases the quick solutions made b…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now