Server Event Log inaccessible from remote server.

A client file server / Domain Controller is giving some strange security problems.  It is running Windows 2003 R2 and in the course of troubeshooting it we tried installing SP2, but it didn't help.  Essentially, we are having problems installing an agent software from their backup application.  However, there are some other issues that seem related to me that may be easier to troubleshoot and get to the root of the problem.  

If I view the event viewer locally on the server, I can view the events.  If I use the MMC and connect to the computer from one of the other Domain Controllers and try to view the Event Log, I get an Access denied error.  Nothing is thrown in the event log of either server when I try to connect so it's not giving me much guidance on what the problem is.  Both servers reside on the same physical subnet.  I can view the event log like this on ANY of the other servers, so I'm guessing this is specific to that server and not the domain itself.  I don't know if this problem existied before, but this domain was renamed about 1 month ago using the domain rename tools.  I have done the following on attempting to troubleshoot:

1. Installed SP2
2. Removed the DC services, remove the server from the domain, re-added it to the domain, re-promoted it.
3. Verified the security on all admin shares
4. Verified file security on the event logs.

None of that helped.  Any suggestions would be greatly appreciated!
LVL 8
SanDiegoComputerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
Try checking the following registry keys on the server in question:

HKLM\SYSTEM\ControlSet001\Control\SecurePipeServers\winreg
HKLM\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg

1.  Run REGEDIT and navigate to one of the above subkeys.
2.  Right click the winreg subkey and choose Permissions.
3.  On the Security tab, click Advanced.
4.  On the Permission tab, there should be an item for the "Local Service" account. Select it and click Edit.
5.  Ensure that the "Local Service" account has the following permission for "This Key and Subkeys" (which can be configured in the "Apply To" list box):

Query Value
Enumerate Subkeys
Notify
Read Control

6.  Check the other subkey with the same steps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SanDiegoComputerAuthor Commented:
Awesome!  I've been doing this for a number of years and worked on this problem for HOURS and that fixed it right away.  The agent software is also installing no problem.  Thanks a bunch!
0
Hypercat (Deb)Commented:
Glad I could help!  Obviously this is something that is supposed to be set correctly automatically, but I ran across it originally on a system upgrade from Win2K server to Win2K3 server. Missing permissions on these keys prevents all sorts of remote admin functions from working.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.