Solved

Remote Desktop Connection v6.06 default username

Posted on 2007-04-09
27
5,533 Views
Last Modified: 2013-11-21
My client is running WIndows XP SP2 with Remote Desktop Connection v6.06.  When users attempt to connect to the Windows Server 2003 terminal server (or any server for that matter), the RDC authenication window that pops up defaults the username to <servername>\<username> when it should default to <domain>\<username> or just <username>.  The users do not have local computer logons to ANY server and so they have to "fix" the username each time they need to use the terminal server.

Is there a way to change this, so that RDC v6 defaults to <domain>\<username>?
0
Comment
Question by:psandak
  • 10
  • 7
  • 4
  • +4
27 Comments
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877367
Under the General tab of mstsc>Options>General, what is stored there?

There is a GPO for remote desktop as well, to Store credentials. Ill need to find it....
0
 
LVL 1

Expert Comment

by:help-me
ID: 18877383
try editing Default.rdp
see http://support.microsoft.com/kb/885187
0
 

Author Comment

by:psandak
ID: 18877407
Not much is stored in the general tab.

There is a drop down menu for the server list.
the username says "(none)" and below it says, "You will be asked for credentials when you connect"

It is when you click connect that the username is set to <servername>\<username> and there is no apparent way to change it, other than to check the "remember me" checkbox which bypasses the logon process which the client does not want to do.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18877453
What about
Start->Run->mstsc
Click OPtions
Enter the info there and click Save As, saving it as Default.rdp up under the user's profile\My Documents folder....

Next time you open it - it should use that file's settings...
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 18877461
Yes Locate the users default.rdp file (usually in my documents) open it with notepad or wordpad

add / edit the following two lines

username:s:{your username}
domain:s:{your domain name}

Close and save the file
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 18877467
pah! far to slow today
0
 

Author Comment

by:psandak
ID: 18877471
"sirbounty:
What about
Start->Run->mstsc
Click OPtions
Enter the info there and click Save As, saving it as Default.rdp up under the user's profile\My Documents folder....

Next time you open it - it should use that file's settings..."

There is no place to enter information.  Unlike version 5 where you can enter information and save the default.rdp, in version 6 yes you can save it but there is no information boxes except the server name
0
 

Author Comment

by:psandak
ID: 18877482
"PeteLong:

Yes Locate the users default.rdp file (usually in my documents) open it with notepad or wordpad

add / edit the following two lines

username:s:{your username}
domain:s:{your domain name}

Close and save the file"

None of the users have a saved default.rdp they simply launch mstsc from run, change the server if necessary and click connect.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 18877532
once you open mstsc once you will get a default.rdp file
0
 

Author Comment

by:psandak
ID: 18877542
I found the hidden deafult.rdp file and opened it with notepad and I did as PeteLong said and it did not work.

When you click connect the username remains <servername>\<username>
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18877561
If you save over the existing one (it may be the older version?) - it should prompt you with a blank credentials box...
0
 

Author Comment

by:psandak
ID: 18877598
"sirbounty:
If you save over the existing one (it may be the older version?) - it should prompt you with a blank credentials box..."

I deleted the current default.rdp and had the system recreate it and when I entered the server name and clicked connect I got the same <servername>\<username>
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18877618
Try this:

Start->Run->MStsc <Enter>
Click Options
Remove the computername (highlight and click <Del>)
Click Save As - save as Default.RDP in My Documents folder, choosing to overwrite the file.
Close out the session.

Restart Mstsc - it should use that default.rdp and prompt you for credentials...
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:psandak
ID: 18877658
"sirbounty:
Try this:

Start->Run->MStsc <Enter>
Click Options
Remove the computername (highlight and click <Del>)
Click Save As - save as Default.RDP in My Documents folder, choosing to overwrite the file.
Close out the session.

Restart Mstsc - it should use that default.rdp and prompt you for credentials..."

Did this exactly and got the same result <servername>\<username> in the credentials window
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877659
"There is no place to enter information.  Unlike version 5 where you can enter information and save the default.rdp, in version 6 yes you can save it but there is no information boxes except the server name"

Could you clarify this? You can edit the same things and more, in mstsc>options>, lots more than just a server name....Maybe I misunderstood this comment though...too much chocolate yesterday...   :)

If a password is stored, you can click Edit or Delete these credentials, under where it displays who you are going to connect as....
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18877688
Actually, from the help file:

If your computer is part of a domain, you can't save your credentials when you connect to a remote computer.

But it shouldn't be keeping the servername either...
0
 

Author Comment

by:psandak
ID: 18877709
"johnb6767:
"There is no place to enter information.  Unlike version 5 where you can enter information and save the default.rdp, in version 6 yes you can save it but there is no information boxes except the server name"

Could you clarify this? You can edit the same things and more, in mstsc>options>, lots more than just a server name....Maybe I misunderstood this comment though...too much chocolate yesterday...   :)

If a password is stored, you can click Edit or Delete these credentials, under where it displays who you are going to connect as...."

I run version 5 on my laptop (because I have simply not upgraded yet and when you go into the RDP options there are connection options: computer, username, password, domain and a save my password checkbox.  You can then save these options as a separate RDP connection, believe me I know I have many of these files saved.

In version 6 however they took out these editable options from the general tab.  the only change you can save is the server name.  Once you click connect a window appears that you enter your domain\username and password and there is a checkbox to save your password and then these settings stick, BUT the customer does not want the users to save their passwords in this manner for security reasons.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877718
There is a reg edit that allows it...I have several .rdp files on my desktop that stored the credentials....When prompting to edit, it opens the Local "Control userpasswords2>Advanced>Manage Passwords" dialog

Just need to find it.....
0
 

Author Comment

by:psandak
ID: 18877729
sirbounty:Actually, from the help file:

If your computer is part of a domain, you can't save your credentials when you connect to a remote computer.

But it shouldn't be keeping the servername either...

I think the customer would accept having to enter the username if it was not present, but it is and they want to know how to permanently change it even to just get rid of it.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877758
Now I got a visual of that boxes you are talking about........
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 125 total points
ID: 18877761
http://blogs.msdn.com/ts/archive/2007/01/22/vista-remote-desktop-connection-authentication-faq.aspx#_How_to_remove

How to remove invalid pre-populated domain names
Some users have noticed that an invalid pre-populated domain name is placed in front of the user name in the credential dialog. Users are frustrated at having to delete this bad domain on every connection. The sequence of steps causing this behavior is as follows:

User wants to connect to a machine via IP address, say 127.0.0.1.
He enters the correct password and username “Administrator”. He successfully logs on.
The next time he attempts to connect to 127.0.0.1, he sees in the “User name” field of the credentials dialog “127.0.0.1\Administrator”. The user deletes the text “127.0.0.1\” from the user name field and logs on. On successive connections, he is forced to keep deleting this extraneous text.
Answer: When a domain is not presented for the username, Remote Desktop assumes by default that a local server account will be used and the domain name is pre-filled accordingly. In this case, the server name entered was “127.0.0.1”, and as a result, the domain entered was the same. This was done for various reasons in Vista that are too complicated (and irrelevant) to go into detail here.

The best workaround for this behavior is to always enter a proper domain into the credentials dialog. If you are connecting to machine “MyMachine” using the “Administrator” account, do not just enter “Administrator” as the username, enter “MyMachine\Administrator”. From there on out, the proper domain and username will be prepopulated in the credentials dialog. Alternatively, if the user account is an account named “DomainUser” in the domain “MyDomain”, use “MyDomain\DomainUser” instead of just “DomainUser”.
0
 

Author Comment

by:psandak
ID: 18877794
Ok johnb you've posted EXACTLY what's happening.

But i have tried to do this over and over again with no success.  How do you clear out ALL the information that Windows has on RDP?  I have tried deleting the Default.rdp file in My Documents without success.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877855
Are there any other default.rdp's like in All users?
0
 

Author Comment

by:psandak
ID: 18877859
johnb thank you.  what I did not think to do was have the user manually change the logon to domainname\username and actually logon to the TS.  this fixed the problem
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18877956
Cool....Glad we got it worked out quickly....
0
 

Expert Comment

by:brendal30
ID: 18907777
How about editing the RDP file using notepad?  I've a template RDP file that I edit using notepad and the only thing I do is change the server name and username and leave the rest as is.  

This came in handy when Microsoft decided NOT to include usename/passowrd/domain entry option on the new RDP client for non Vista updates.

The new RDP client prompts for username/password/domain prior to establishing connection and there is no work around it (with the exception of gpedit.msc vista solution)
1.  Click the Start button , type gpedit.msc, and then press ENTER.&#8204; If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
 
2.  Under Computer Configuration, double-click Administrative Templates, double-click System, and then double-click Credentials Delegation.
 
3.  In the right pane, double-click Allow Saved Credentials with NTLM-only Server Authentication.
 
4.  In the dialog box that appears, click Enabled, and then click Show.
 
5.  In the Show Contents dialog box, click Add, type the name of the remote computer (server) in this format: TERMSRV\<computername>, and then click OK.

NoteBe sure to capitalize “TERMSRV” as shown. <computername> can either be the name of a specific remote computer (for example, TERMSRV/myremotepc) or you can use an asterisk (*) to include a group of computers (for example, TERMSRV/* or TERMSRV/*.corp.com). <computername> should exactly match the name you enter in the Computer box in Remote Desktop to connect to that remote computer.

For non-vista approach, notepad edit seems to work best.  Sample of the RDP code:
1 - edit the RDP file using NotePad - server.rdp - replace servername and username@domain.com

screen mode id:i:2
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:16
winposstr:s:0,3,0,0,800,600
full address:s:servername
compression:i:1
keyboardhook:i:2
audiomode:i:0
redirectdrives:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
displayconnectionbar:i:1
autoreconnection enabled:i:1
username:s:username@domain.com
domain:s:
alternate shell:s:
shell working directory:s:
password 51:b:01000000D08C9DDF0115D1118C7A00C04FC297EB010000009187DC485A0C994CAB4C29371C388DC40000000008000000700073007700000003660000A800000010000000FD805AAEA4A4FB52D64FC3AE804904F70000000004800000A000000010000000CAC97C25733A7D36A78C1FFD6D3EBE300802000081C828A3F574E30E237A0306DA64C84053D534EFC1C85CBC9050833A643E8BED35D238C5868D93A749494AE570F4CB27AA6E44BAC6C1B44BDB112A37D4725741C07912CDB351564B75CEF41D7C0ABE0F732ECA8AB0AE221F25A7A2A588556D50722155167E028B77D90E322CD389D5DFC8F617F20ADE7F5A7451B55D6EF713D8104A04EBC416CAF0F5EBCB054C29F749CFC38C52E78509404CE89CBA9E6015BA713879FB8EAF163E04688DDFB361B45F32E0AB3332E4A3F4FCA3305B6F29B66210C9C84F155E4325DE7291E27C71BD31133534DD15F841E950C57D1AA2B356095BD86ABF03FD8D980BB8BFA30EADA0001B928E4A181562CC0E4621788D79B50A8326504166DDB5E210CB15EE62F3920FCC0609446DABDC7FAEEC95EDD75C3CC3F9FFCFCB923C117CCEE1EBCF3DA35F41A133AF8B786BAB159A2E56886DD22ECE7B4D4A6A3101C86F9CD2D6871EF4BF6E2A6235434670FDA88B5DA2100A299A4F3258CDD12A6A8D940F22D31D7DD5EFCACFCD181E259A9B92B121D8588A193FC57B5C47E63EF3883AABA274D4C5396D980ECBCCCDBA4DF2F9292E4269CDD0B936387ED095B91AF06CA0ADA7F234CF363DF15F1C196C39AE2845DB097653684C7F0EB2340A5F117DFF062009531FD2C1D0E576339E6E1DA83B0CBFE5F8F697306FFE8CDF9D442D7ACA1B8BE5FD99B44EADC639FA55BA65880A069F267A293447ED4A716E8BDE2B991F14000000AB3E1EC800896318DD0CE7E20E3171A8B865E08D0
disable wallpaper:i:1
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
 
 
0
 
LVL 1

Expert Comment

by:softecsolutions
ID: 23055153
Someone asked how to clear all the rdp information from a workstation.  I don't think it was really answered.  Run regedit, then current user/software/microsoft/terminal server client\default.  It is there that you will find the terminal servers that the workstation has communicated with.  A great way to clean up where you have been on a public computer.  Remember to delete the default.rdp too, if you really need to clean up.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now