Killing RSH in Solaris 10

I need to disable this and cant find out how.  When I usee an inetadm,  rsh is not listed there.
How can I kill it?  RSH listens on tcp 514 right?

Thanks
dissolvedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
Look in /etc/inetd.conf
remove the line "shell stream tcp nowait root /usr/sbin/in.rshd n.rshd"
restart the inetd daemon with "kill -HUP pid", where pid is the inetd daemons process id
0
dissolvedAuthor Commented:
negative. This is Solaris 10. inetd.conf is pretty much empty.
0
TintinCommented:
svcadm disable svc:/network/shell:default
svcadm disable svc:/network/shell:kshell

kshell is the kerborised version of rshd.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.