Disabling X server in Solaris 10

How do I  disable Xserver in Solaris 10?

Will this kill all x related services?
dissolvedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nixfreakCommented:
Not sure about your question but to disable dtlogin run:
/usr/dt/bin/dtconfig -d
0
dissolvedAuthor Commented:
I want to kill X11 port 6000 from listening. Is there a way?
0
nixfreakCommented:
Change this line in /usr/dt/config/Xservers:
  :0   Local local_uid@console root /usr/X11/bin/Xserver :0 -nobanner

To:
  :0   Local local_uid@console root /usr/X11/bin/Xserver :0 -nobanner -nolisten tcp
0
nixfreakCommented:
Or better still run this command:

# svccfg -s svc:/application/x11/x11-server setprop options/tcp_listen = false
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.