File Permissions Windows 2003

I installed Apache 2.2 on Windows Server 2003.
by default, htdocs is buried in Program Files on the C drive.
My D Drive has a TON of room, so I created a new htdocs on my D drive, edited the conf file to set Doc Root to the D:\htdocs.

Now I get Forbidden errors in my browser.
What sort of permissions and what not do I need to assign to my new folder?  I checked permissions from the old folder to my new one, they look the same.
Is there anything else in Apache I need to do to make it (happily) use the new folder?
LVL 1
dougp23Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

giltjrCommented:
Did it work before?  Check to see what you have for the directory definition for "/".  IIRC it should follow the "DocumentRoot" statement and by default looks like:

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>

Which means that by default nobody can look at it.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
I am curious why you would be using Apache on Windows Server when IIS 6 is included and by many accounts, more secure.  If you review security announcements, there have been far more for Apache than IIS 6 over the past few years...
0
dougp23Author Commented:
giltjr, is that how it SHOULD look, or how it SHOULDN'T look?

I can get the index page up.  But if I create another folder, I can't write to it.
As far as Apache Vs IIS goes, I just like Apache better.
0
giltjrCommented:
That is how it looks by default.  Which means nobody can see it.  You may want to change to:

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
#    Deny from all
    Allow from all
    Satisfy all
</Directory>
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samriCommented:
hi Doug,

I had tried with my apache 2.0.51 (unfortunately) on winXP sp2.

I had created a dir on my S: Drive, called S:\Htdocs

and in my apache config file (httpd.conf).  THere is sometihng about forward slash (/), and backslassh (\), I think.

#DocumentRoot "C:/Program Files/Apache Group/Apache2/htdocs"
DocumentRoot "S:/Htdocs"

#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.  
#
<Directory />
    Options FollowSymLinks Indexes
    AllowOverride None
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
#<Directory "C:/Program Files/Apache Group/Apache2/htdocs">
<Directory "S:/Htdocs">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs-2.0/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride None

#
# Controls who can get stuff from this server.
#
    Order allow,deny
    Allow from all

</Directory>
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.