exchange 2007 with activesync to windows mobile 5 trouble

I cannot get my verizon vx6700 phone to sync with my exchage 2007 server.  The pocket pc gives me the error code 0x8501004.  I have just done a full reset of this device, and installed the DST2007 update and my root certificate for the SSL to my exchange server.  (note: i can get this to work just fine one of our exchange 2003 servers).

On the exchange 2007 box i get the following error in the event log (Event ID 1021):
A non-compliant device is attempting to connect with Exchange ActiveSync, but the Exchange ActiveSync mailbox policy for user [malatex\djohnson] and device id [24B1FD9CD5683998C9F87285382978E0] requires devices to be compliant before syncronizing with Exchange ActiveSync.

So far i have verified that i have enabled activesync in the exchange control panel for this user account, and also used the command line to enter the command as well (i saw this on another post).

Any help or ideas would be apprecited to help resolve this issue for me.

Thanks everyone for your time & input!!!
danej256Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
You need to look at your ActiveSync policy.
EMC, Org Config, Client Access.
Check whether the policy allows non-provisioned devices to access the server.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
danej256Author Commented:
Thanks Sembee for the response.

I have tried this and i get the same results.  I have also tried it with no device defined in the EMC, Org Config, Client Access.  Also in this area i am leaving all password stuff unchecked.
0
SembeeCommented:
Have you set the user account with an Active Sync policy?

Simon.
0
danej256Author Commented:
This is working now, i deleted my activesync mail policy and did it from scratch again.  And now it is working.  So not sure what fixed it, maybe it just took an hour to take effect??!!

Thanks for the help with this issue.  I will provide you your points for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.