Solved

Access denied when trying to open newly created local mapped network drive.

Posted on 2007-04-11
24
676 Views
Last Modified: 2008-10-15
I have a Windows 2003 Server R2 standard setup.  When I map a drive on a new account created ON the server it shows that it is mapped, however, when I try to access the mapped drive it says access denied.  However, I can go to the folder locally on the server and access all of the information.  I have to have the drive mapped for the application we are using to work properly.  I have checked the permissions and I am stuck.  I do know that the administrator account maps fine and works properly.  Please advise
0
Comment
Question by:stallings123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 10
24 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 18890559
You're looking at the security permissions - you need to modify the sharing permissions, which be default in W2k3 is Everyone/Read Only.
Change it to Everyone/Full and you should be all set! :^)
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18890565
From the server - right-click the folder where the share is housed, and choose properties (or sharing and security) and then from the sharing tab, adjust the permissions there to Everyone/Full (or for tighter security, Authenticated Users/Full)
0
 

Author Comment

by:stallings123
ID: 18890634
That is already shared that way.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 67

Expert Comment

by:sirbounty
ID: 18890656
Can you post the results of the following: (run from the server)

Start->Run->CMD /C Cacls C:\YourFolderName > C:\Cacls.txt && c:\cacls.txt
0
 

Author Comment

by:stallings123
ID: 18890708
e:\apps\OMNI7 BUILTIN\Administrators:(OI)(CI)F
              CREATOR OWNER:(OI)(CI)(IO)F
              Everyone:(OI)(CI)F
              NT AUTHORITY\SYSTEM:(OI)(CI)F
              BUILTIN\Users:(CI)(special access:)

                                SYNCHRONIZE
                                FILE_WRITE_DATA
 
              BUILTIN\Users:(CI)(special access:)

                                SYNCHRONIZE
                                FILE_APPEND_DATA
 
              BUILTIN\Users:(OI)(CI)R
0
 

Author Comment

by:stallings123
ID: 18890719
e:\ BUILTIN\Administrators:(OI)(CI)F
    CREATOR OWNER:(OI)(CI)(IO)F
    Everyone:(OI)(CI)F
    NT AUTHORITY\SYSTEM:(OI)(CI)F
    BUILTIN\Users:(CI)(IO)(special access:)

                          SYNCHRONIZE
                          FILE_WRITE_DATA
 
    BUILTIN\Users:(CI)(special access:)

                      SYNCHRONIZE
                      FILE_APPEND_DATA
 
    BUILTIN\Users:(OI)(CI)R

0
 

Author Comment

by:stallings123
ID: 18890729
e: drive partition is shared then omni7 which is buried within e:\apps shared
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18890772
Try unsharing it...use this method if you'd like (from a command prompt)
(and I'd remove "Everyone:F" from the security...

net share Omni /delete
net share Omni=e:\apps\omni

Then right-click the share and double-check Everyone account - it should be set to Read by default - change it to Full.

Next, on the security - open it up and click Advanced on the security tab, checking the 'change permissions on all child objects' as well...
0
 

Author Comment

by:stallings123
ID: 18894940
Still did not work.
0
 

Author Comment

by:stallings123
ID: 18894943
This is driving us crazy.  We can access all day with the administrator account.  If we make and user member of the administrator group it still does not work.  We tried copying to another folder and recieved the same error.  
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18895432
Just a stab in the dark, but can you check tcp filtering?

Start->Run->ncpa.cpl
Right-click your lan, choose properties
Internet Protocol, Properties
Advanced, Options, Properties
Is that enabled and/or set to All?
0
 

Author Comment

by:stallings123
ID: 18895453
set to permit all
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18895462
Okay, so locally you can access e:\apps\OMNI7 as the administrator 'or' any other account?

But remotely, you can only access \\servername\omni7 as the administrator - that correct?
0
 

Author Comment

by:stallings123
ID: 18895479
Yes I think that is it.  If I log in under the administrator account I can access the mapped o: drive which is mapped to e:\apps\omni7 (which omni7 is the shared folder) the executable is netomni.exe which is in a folder called progs e:\apps\omni7\progs.  I can map an o: drive to e:\apps\omni7\progs and run the executable but not if I do it the way the admin account is setup.  With any user that has rmeote access permissions I can map to any folder and access with no problems.  It is only this folder I am having the troubles with.  Also, if I am logged in as one of the remote users(not administrator account) I can run the program from a shortcut directly to the e: drive just not if it is mapped to the o:
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18895488
Wait...are you mapping it to omni like this:

net use o: \\servername\e$\apps\omni7 ??
0
 

Author Comment

by:stallings123
ID: 18895528
there is an e$ administrative share.  I am not using the command line to map the drive.  I am right clicking on the folder.  
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18895534
Right - ordinary users won't have access to e$, you'll need to use a share name.

Instead of \\server\e$\apps\omni7
they'll need to use
\\server\omni7
0
 

Author Comment

by:stallings123
ID: 18895549
that is what we are doing.  when we map o: to \\ibsldc\omni7 it will show the shared drive in my computer but when you click on it you will get a red x and says access denied.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 18895556
Hmm - tough one to troubleshoot remotely, I'm afraid...
I'll take another peek at this in the morning when my brain is fresh...hopefully we'll get something sorted for you soon!
0
 

Author Comment

by:stallings123
ID: 18902866
Did you come up with anything?
0
 
LVL 67

Accepted Solution

by:
sirbounty earned 500 total points
ID: 18904856
http://support.microsoft.com/kb/310399 details how to turn on auditing (just do it on the server).  Check the security log afterwards (you'll need to enable auditing on that specific folder) and see if you can identify what's actually being restricted (audit both success and failures).

Also - while in the security of that folder, click Advanced - and from the Effective Permissions tab, enter the account that you're testing with - and see what the effective permissions are returning...I can't help but wonder that there's a deny in there somewhere...
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question