Solved

sftp in solaris

Posted on 2007-04-11
4
4,990 Views
Last Modified: 2013-12-27
All.... here is my log.....
Steps
1. ssh-keygen  -t rsa ,2 keys formed
2. copy .pub file to unix server
3.cp *.pub authorized_keys
  chmod 600 authorized_keys
  cp id_rsa.pub authorized_keys2
   chmod 600 authorized_keys2

sftp -v -v -v user4567@serverloc3
it is asking for a password.... even though I have no parapharase setup for testing.Am I doing any thing wrong
debug1: Found key in /home/user4567/.ssh/known_hosts:1
debug2: bits set: 530/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/user4567/.ssh/id_rsa (0x0)
debug2: key: /home/user4567/.ssh/id_dsa (0x0)
debug1: Authentications that can continue: gssapi-keyex,gssapi-with-mic,publicke
y,password,keyboard-interactive
debug3: start over, passed a different list gssapi-keyex,gssapi-with-mic,publick
ey,password,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/user4567/.ssh/id_rsa
debug1: read PEM private key done: type RSA
debug3: sign_and_send_pubkey
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: gssapi-keyex,gssapi-with-mic,publicke
y,password,keyboard-interactive
0
Comment
Question by:prgeorge3383
  • 2
  • 2
4 Comments
 

Author Comment

by:prgeorge3383
ID: 18893840
the user’s home directory, .ssh directory, and authorized_keys file must not be group- or world-writable.

run sshd in debug mode
cat /var/log/secure  will show the errors

these are the permissions needed

775 for all the directries
600 for authorized_keys

works good now
0
 
LVL 38

Expert Comment

by:yuzh
ID: 18894937
Hi prgeorge3383,

    You solved the problem by yourself,  can I PAQ the question and refund the points to you?
   
   yuzh
Page Editor
0
 

Author Comment

by:prgeorge3383
ID: 18898193
please do...
but please do not delete the question and answer since it is  very useful for others
0
 
LVL 38

Accepted Solution

by:
yuzh earned 0 total points
ID: 18902776
PAQ and refund (500 points)
     yuzh
Page Editor
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question