"The specified color profile is invalid"

I'm getting the error message "Printer driver was not installed. The specified color profile is invalid." when installing a printer on the printserver. The printer I'm trying to install is a HP Color LaserJet 2840.

I've tried to replace the "icm32.dll" file with the one in "C:\Windows\ServicePackFiles\i386", this did not work.

I've tried both PS and PCL driver, but the same problem appears.

The printserver is runnning Windows 2003 server with SP1.

Is there any solution for this?
HFK-IKTAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

65tdRetiredCommented:
On the print server go server properties remove the driver,  restart the spooler, try adding the driver again.
0
HFK-IKTAuthor Commented:
This did not work. The same problem appears.
0
65tdRetiredCommented:
How many printers of this type are on the P server?
I assume the drivers are being installed on the print server and by what access RDP, locally logged on?
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

HFK-IKTAuthor Commented:
This is the first printer of this type.
I have tried to install the printer through RDP and RDP Console.

The printserver have 219 printers installed.

Every time I try to install the driver a .tmp file is created in "C:\Windows\System32\spool\drivers\color"., SET1D.tmp etc.



0
HFK-IKTAuthor Commented:
The problem was fixed after a restart of the server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marksheeksCommented:
I have the same issue. cannot reboot the server. Reboot is not necesarily a solution in my mind. anyone knows what's causing it?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.