We help IT Professionals succeed at work.
Get Started

Configuring RDC on a PIX501 problem

193 Views
Last Modified: 2013-11-21
Trying to configure this PIX 501.
There are 2 locations and 2 pix's, of course a VPN connecting the 2 locations.
Location1 is the 192.168.0.0 network
Location 2 is the 192.168.2.0 network
Location 1 is where the problem is, i am trying to open a remote desktop port to access the server.
Here is the configuration i have now, the tunnel is up and running and everyone has access to the internet between the 2 locations.
I just can't get in from the outside, and i have a feeling i'm just over looking something simple.
Can someone please help me out with this issue?
Thank you
   Jay

Result of firewall command: "sh run"
 
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password bBavqhSwJUinW3Pe encrypted
passwd bBavqhSwJUinW3Pe encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service remotedesktop tcp
  port-object range 3389 3389
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_access_in permit tcp host XX.XX.XXX.XX host 192.168.0.10
access-list outside_access_in permit tcp interface outside object-group remotedesktop host 192.168.0.10 object-group remotedesktop
access-list acl_out permit tcp any host XX.XX.XXX.XX eq 3389
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XX.XX.XXX.XX 255.0.0.0 pppoe setroute
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.2.0 255.255.255.0 outside
pdm location 192.168.0.10 255.255.255.255 inside
pdm location 192.168.0.10 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 3389 192.168.0.10
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (outside,inside) tcp XX.XX.XXX.XX 3389 192.168.0.10 3389 netmask 255.255.255.255 0 0
static (outside,inside) XX.XX.XXX.XX 192.168.0.10 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 74.218.82.18
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address XX.XX.XXX.XX netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet XX.0.0.0 255.0.0.0 outside
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname plushcdsl@wcoil.com
vpdn group pppoe_group ppp authentication pap
vpdn username xxxxxxxxxx@xxxx.com password *********
dhcpd auto_config outside
terminal width 80
Cryptochecksum:8c6729a84ddc243dc4d063ac14296a24
: end

Thanks again!
Comment
Watch Question
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE