Avatar of nerdzoll
 asked on

Oracle JInitiator + Forms + IE = Crash

Hi Guys we have begun having a problem with many of our computers at work the last few days. When we attempt to connect to Oracle 9i forms (using JInitiator (iirc)) the following occurs:

Internet Explorer has encountered a problem and needs to close.  We are sorry for the inconvenience.  If you were in the middle of something, the information you were looking on might be lost.

For more information about this error, click here.

(When Click Here is Clicked):
Error signature
AppName:  iexplorer.exe   AppVer: 7.0.5730.11    ModName:  jvm.dll
ModVer:    Offset: 000495ba

This has occured for the following question but no solution was ever found other than it must be IE 7 (https://www.experts-exchange.com/questions/22467309/Oracle-9i-Forms-Runtime-Browser-Crashes.html?sfQueryTermInfo=1+jiniti+jvm.dll)

However we are having the same issue on XP Machines running IE6 & IE7. We thought that perhaps sun java was causing the issue but several of the machines do not even have another java environment installed.

It is driving us batty (and our clients too) and as Firefox is not currently supported for the products to use we can non say "Use Firefox" as a work around.

Any ideas/assistance would be OUTSTANDING.
Oracle DatabaseWeb Browsers

Avatar of undefined
Last Comment

8/22/2022 - Mon

Have you turned off the default firewall of XP?

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.


Hi schwertner
All firewalls in XP are turned off. I have attempted disabling all Internet Explorer addons bar JInitiator.
As for rolling back to IE6, we are having the issue in both IE6 & IE7 so this wont really be an option for us.
Oh and thank you for the 10G link)
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy

I have heard that some times the reason for what you observe
is turned ON "Popup blocker" in the IE6/7.
I am worried by your message because Oracle E-Business Suite
uses Jinitiator and such a threath you describe will be full desaster.

Hi Guys,
Thanks for all your help so far.
What we have done is the following. We have found two workarounds, and we feel that we are close to pinning this down to a culprate.

Workaround 1:
Disable all 3rd party browser extensions in IE (works every time so far).

Workaround 2:
Install the latest version of Java from www.java.com, take the jvm.dll from there and put it in the JInitiator hotspot directory, then reboot the computer. This one has worked every time as well.

Now what we think the cause is, is a Mcaffee Browser Helper Object. IT appears when we disable just that one extension that everything works again. All of our computers have Mcaffee, hence the problem.

Oh and Schwertner, We use E-Business Suite hence why we were running around like headless chickens.

I will keep this updated as we troubleshoot more and hear more. I feel that it would be a good addition to the library when we find a fix for this. Currently talking to Oracle more.

Ok Guys,
Here is what has occured. After speaking to oracle they have suggested turning of all toolbars in IE as the fix.

We still maintain that our workaround is better however we have been told the cause is that a lot of the toolbars cannot handle the older version of Java that J-Initiator is using.

Firefox is also another work around, it seems to be able to handle the different versions of java (or perhaps it is just noone has tested it with the toolbars installed).

In the end we used the jvm.dll from JDK1.5r11 as that is known to work with Oracle. However the fact that we have replaced the J-Initiator JVM.DLL is not actually supported by oracle.

Thanks for everyones help and I hope if someone finds this that this helps em out.
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.

Thank you very much!

Good job!

We are concerned reading your posting, because my wife
working as professor is introducing lectures in Oracle
E-Business-Suite. Sometimes she has also troubles
accessing the Oracle Stack.

Removed Live Toolbar.

Removed JInitiator.

Reinstalled latest java.

Reinstalled JInitiator.

Cleared all IE settings, added site to Trusted Sites.

Solved... Honestly. I think it was the windows live toolbar that was causing the issue.

The helpdesk number I used was 888-704-4400 and was virtually useless.


Thank you for the latest input.
This will help many people.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.

Hi anyone who reads this - Just an FYI...

Had exactly the same problem as above - As soon as you try to navigate to the Oracle form, IE crashed with exactly the same error.

I only tried ONE of the above suggestions - Removing Windows Live Toolbar. Now all works ok, so I think that makes for a pretty convincing case that it's the toolbar causing the problem!

Just thought i'd add this for extra clarification.



For me it was removing the CPwmIEBrowserHelper from Lenovo.  Once that was removed that removed 90% of my crashes.  And as an extra bonus IE 7 starts much, much faster.

I have tried all the suggestions and nothing is helping anymore. Before, deleting cookies and temp internet files use to resolve the issue temporarily, but now it does not. We have tried sooo many things and have not been able to get this to work for us anymore... Trying to work with Oracle support, but since they can get to everything with no problems, they don't seem to be very willing and helpful.

Any other suggestions would be GREATLY appreciated!

Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.

Crossmatch: Is using Firefox an option for you?  That solved the issue here 100%.

When I tried to use Firefox, it kept asking to install Jinitiator even though it was installed already... I did just try some other steps and it seems to be working! Keeping my fingers crossed... Here is what I did:

- Delete Cookies, Temporary Internet Files.

- Close ALL Internet Explorer windows.
- Uninstall Java instances (not Jinitiator)

**There will probably be a lot more listed than shown in this screenshot.
- Reinstall Java

- After install is complete, install the most current Jinitiator. ( is the one I just downloaded)

- Now copy the jvm.dll file from the Program Files\Java folder to the Program Files\Oracle\jinitiator hotspot folders (rename the jvm.dll currently in the folder to jvm.dll.old)

This seemed to work. Will let you know if it doesn't. Thanks! This was driving me crazy :-)

When using Firefox you will have to re-install j-initiator.  However once that's done it seems to work okay.  Good luck on your current solution.
Your help has saved me hundreds of hours of internet surfing.

In our case, it was a problem with having DEP turned on.  Once I turned it off and rebooted, all was well

I installed Firefox and it resolved my issue with Oracle/IE. Not mention when it downloaded files it showed a progress bar instead of apprearing to hang (IE apprears to hang).

Hi everyone,

We have been doing a number of things to resolve this. All seem to work for awhile, and then different things happen. IE crashes with the jvm.dll module in event viewer; IE closes leaving a log file on the desktop; IE crashes with just the "red x" window and an application popup event viewer log....
Here is what we usually do:
1. We do the jvm.dll trick mentioned in this thread by the author. Most of the time, it works. Sometimes it doesn't, and sometimes the problem comes back.
2. Change DEP to make an exception for javaw.exe. This seems to work a lot also, but sometimes it doesn't.
3. Disabling all add-ons in IE, except the Sun Java Console add-on, when we tried disabling, then Java wouldn't even start. Again, sometimes it helps, and others it doesn't.
4. Update Java. Sometimes, Java needs an update, and this will fix it, but this is usually very temporary and by the next day, IE is crashing again.
5. Uninstall all JInitiators, delete the C:\Program Files\Oracle folder, reinstall JInitiator

One of these steps usually work. But we have not found a sound solution that works all the time and fixes it permanently.

We've also had problems with Google Toolbar in some instances.

It's VERY frustrating since it isn't steady in symptoms!
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Mohammed Basheer

Dears, Its now my turn to suffer this exact problem, thanks for your all inputs which helped me in my troubleshooting steps, but the problems still there. The only step that i want to test is turn off the DEP, which i will do today. Have you found out any permanent solution lately? If,  i appreciate your sharing here.

Thanks again

We have not found a permanent solution yet...

Also! Sometimes running Windows Updates and installing does the trick.

Again, there isn't 1 solution that works for all instances yet. We usually go through all of the steps mentioned in our last comment until something works.

Sorry we don't have a more solid solution.

P.S. I am attaching the jvm file that we use. You will need to save it then rename the extension to .dll


I just had IE crash on me when I accessed Oracle.
The only thing I did on my system was I disabled the Web Anti-Virus Statistics add-on. Closed all IE windows. Re-opened IE, verified that add-on was still disabled, and then accessed Oracle again successfully.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Mohammed Basheer

Back. After one week, i did try disabling the DEP, added the switch 'always off'. It made me success. In my case it was DEP the problem.

Thanks to all for your helpful feedbacks

What is DEP and how do we turn it off?
Mohammed Basheer

Data Execution Prevention. The following link from MS explains it better:

Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.

just to add another fix for this problem and sorry for rebumping this old thread

In IE go to Manage Add-on and see if JInitiator is in the list and Enabled.
If it's not there, go to Internet Options, Advanced and scroll down until the Java (Sun) option.
Uncheck the "Use JRE 1.6.xxx for <applet> (requires restart)" and restart your IE.
Afterwards, go back to Manage Add-on and make sure Jinitiator is present and enabled.
Try login in again and the java program should work now again.
You may recheck "Use JRE 1.6.xxx for <applet> (requires restart)" in Advanced Internet Options afterwards.


We just started to see this issue. The fix listed below fixes the issue and allows you to keep your add ons.
This is the fix for the browser crashing when you try to run JInitiator.

Copy the jvm.dll from
 Your (directory)
 C:\Program Files\Java\jre1.6.0_07\bin\client  
 to (directory)
 C:\Program Files\Oracle\JInitiator\bin\hotspot

Install Oracle 8 and it will most probably resolve the issue.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck

The following solution suggested by "perlly" worked! Thanks a ton!

Copy the jvm.dll from
 Your (directory)
 C:\Program Files\Java\jre1.6.0_07\bin\client  
 to (directory)
 C:\Program Files\Oracle\JInitiator\bin\hotspot

Have the same issue, seems that Office 2010 puts some addons in IE that cause the same issue... Having fun in determining which ones are causing it...