Dial-up error 720 @ Windows XP

mixelogj
mixelogj used Ask the Experts™
on
Hello everyone,
   I have a Thinkpad T43 which once upon a time could use it's intergrated dial-up modem flawlessly. Then, after a while of not trying to use the modem, I tried to connect through dial-up and got a 720 error after my login credidentials were verified. It reads "A connection to the remote compuyter could not be established. You might need to change the networks settings for this connection."
  Now, I have googled for this problem and apparently it's not rare. However, not solution I could find worked for me. First off, the modem passes all diagnostics and I have tried installing four different drivers. Then, I have tried resetting tcp/ip and winsock of windows (XP pro SP2). I have also tried all different options in the dial-up connection and of course also creating new connections and dialing to all sorts of different ISPs.
   Does anyone have a clue what windows bug is this?

Thank you!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi, first you have to setup your internet connection, do you have an ISP?
You need an ISP first then once you have paid for an internet service and can connect to the internet you can then use the other.
Your comment> also creating new connections and dialing to all sorts of different ISPs<< different ISP??? You should have only one the one you paid for this will be your account your ISP.

DUNS ERROR 720
720 - No PPP control protocols configured.

All Operating Systems - This error can occur if you have not configured your Dial-up Networking settings to use a protocol supported by the ISP or system you are calling.
http://www.modemsite.com/56k/duns720.asp
mixelogj which country are you in?
You need to contact your telephone company or a internet service provider pay them for an account usually billed once a month choose a package you can afford they will give you an account and a number to add to your internet connection.
Once you have an account use this guide to run your internet connection.
Setup Details for Windows XP
Dialup Internet Access Services

http://support.floridawebmaster.com/dialup_setupXP.htm

Author

Commented:
Hello,
    I didn't go into much detail for the simple things because it doesn't seem that they matter. I have multiple dial-up accounts I can use, which is how I make the comparison. I have one of my own, a borrowed one and three free internet services. They all fail the same way.
  I have tried all possible settings in the dial-up connection properties, including creating a new connection multiple times. I have reset tcp/ip as well as winsock by the url you paste and others, but it still fails. The most worrying is that dial-up networking was working just fine until 2-3 months ago that this stared happening. I cannot recall any significant and relevant changes i Have made.

Thank you!
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

It all matters to us  mixelogj those little details is our eyes as we have only this page to assist you :)
There may not be anything wrong with the modem but rather the remote
since this is your error>>"A connection to the remote compuyter could not be established. You might need to change the networks settings for this connection."
How long since you attempted a remote connection? you have sp2 as well, what firewall and AV do you have there running?
these are from microsoft
Error 720: No PPP Control Protocols Configured
CAUSE
This behavior can occur if your computer and the RAS server do not have a protocol in common, or if RAS is not configured correctly.
To resolve this behavior, follow these steps: 1. Find out which protocols the RAS server is running, and make sure that the RAS service is installed and configured properly (or ask the Network Administrator to do this).
2. After you find out which protocols the RAS server is running, make sure that your Windows XP-based computer is running one of the same protocols that the RAS server is running:
a.  Click Start, click Control Panel, and then double-click Network Connections.
b.  Under Virtual Private Network, right-click the VPN connection, and then click Properties.
c.  In the VPN Connection Properties dialog box, click the Networking tab, and make sure that you have a protocol that the RAS server is running.
 
3. If you do not have a protocol that the RAS server is running, add the needed protocol:
a.  Click Install, click Protocol, and then click Add.
b.  Click the protocol that you need to install, and then click OK.
c.  Click Close in the VPN Connection Properties dialog box.
 -----------------------------------------------------------
SYMPTOMS
When you try to connect to the Internet with a dial-up connection, you may receive one of the following error messages:
• Error 720: No PPP Control Protocols Configured
• Error 720: Dial-Up networking could not negotiate a compatible set of network protocols you specified in Server Type settings. Check your network configuration in network control panel and try the connection again
CAUSE
This can occur if TCP/IP is damaged or is not bound to your dial-up adapter.
How to Resolve Damaged TCP/IP
1. Click Start, point to Settings, click Control Panel, and then double-click Network.
2. Click TCP/IP that is bound to the dial-up adapter, and then click Remove.
3. This removes the TCP/IP protocol and the Client for Microsoft Networks (if this feature has been installed). Click OK.
4. Restart your computer.
5. Click Start, point to Settings, click Control Panel, and then double-click Network.
6. Click Add, and then double-click Protocols.
7. In the Manufacturers box, click Microsoft, and then double-click TCP/IP in the Network Protocols box.
8. Click OK, and then restart your computer.
to Resolve Missing TCP/IP
1. Click Start, point to Settings, click Control Panel, and then double-click Network.
2. Click Add, and then double-click Protocols.
3. In the Manufacturers box, click Microsoft, and then double-click TCP/IP in the Network Protocols box.
4. Click OK, and then restart your computer.
-------------------------------------------------

Author

Commented:
Hello,
   Yup i've encountered this guide and more when I searched. The bottom part of it seemed interesting but cannot be applied to win xp because you are not allowed to uninstall tcp/ip from dial-up connections. Perhaps i'm looking at the wrong thing, but there is no simply "network" in the control panel. Instead there is "network connections" and "network setup wizard". I couldn't find anywhere that has tcp/ip seem bound to the adapter.
   I am running Kerio personal firewall (I tried disabling it) and norton antivirus coorporate edition (I tried disabling that too). It has been 4 months or so since I last tried to dial-up. It worked fine then. Since that time I do not recall making any changes that could impact it, but sadly you never know. I have tried all sorts of things. Now it doesn't connect to any ISP. It's frustrating :-(

Thank you!
oh dear, okay have a break from it often helps.  :)
We'll solve it hopefully, slowly though.
You have a modem confirmed with no problems.
Do you have a network card installed?<< not confirmed?

there is no simply "network"<< try this, r/click the taskbar properties>click on start menue>customise>advanced>scroll down> My Network Places Tick<  it will show on the start menue below my computer and my documents
scroll down>Network connections>display as a connect to>apply and ok,

 now go to start menue  r/click my network places and show on desktop.
On the desktop r/click my network places  properties> you should see Local area connection.
 r/click this and properties. Here is the tcp/ip

for illistrations only click on the images.
http://www.practicallynetworked.com/sharing/xp_ics/serverdialup.htm
http://www.ucs.ed.ac.uk/nsd/access/dot1xXPwired.html
Merete

Author

Commented:
Hello,
    The problem is located in my ppp stack. The reason is that while I am connected to the internet, trying to log in to a VPN also fails the same way. The problem is how to reset the PPP stack, to which I haven't found the solution yet. I have reset tcp/ip through netsh command line utility, but I cannot uninstall it from a connection's properties (the corresponding button is disabled). From what I understand, that's what you were trying to point me to? Unfortunately win xp doesn't let me uninstall tcp/ip, perhaps due to sp2 but still. The only option that was similar was the command line utility.
   I have more or less decided to format the computer soon-ish. Hopefully that will fix it! Of course if a solution is found until then there is no real reason.

Thank you
can this assist you
PPP.com is supplied as a helpful tool to analyse PPP and Internet protocols.
http://www.inventio.co.uk/PPPcom.htm

Other than that sorry I dont have the answer for that.
Best wishes.
Merete
I have a similar problem (maybe the same).

I get the error 720 "connection to the remote computer could not be established" and it has to do with tcp/ip and/or PPP.

I can connect normally to LAN and WiFi LANs, but using modems (telephone line or 3G mobile phone lines) it is impossible to connect.

I have checked many times the configuration and it is absolutely not a modem configuration problem.

Author

Commented:
I tried out everything I could find online but nothing did the trick. I ended up formatting the whole thing and seriously considering a mac :)
Thanks, I think I will end up doing the same thing, I have been searching for winsock fixes ... etc etc but found nothing.

I have a Thinkpad T41 with IBM Software installed and VPN tools such as AGN Virtual Network Adapter and Hummingbird Socks.

The computer connections were running smoothly including modem connectivity, etc, until one day they just didn't.

Author

Commented:
Exactly. I wish I knew what triggered it, but go figure.

Commented:
Hi Guys. I've been struggling with this same problem (all dial-up connections and a sierra wireless data card). I think i've come across the solution (for the same problem in Win2k anyway):

http://support.microsoft.com/default.aspx?scid=kb;en-us;810979

...the problem is, windows xp wont let you uninstall TCP/IP, nor will it let you remove the "WAN Miniport IP" driver - so im using the " netsh int ip reset c:\log.txt " command, and manually removing the WAN miniport IP driver thru the registry - Not sure how im gonna force windows to reinstall it yet though - will update this topic soon anyway :)

Gene

Commented:
OK. after removing all the WAN Miniport IP drivers reg entries (HKLM>system>enum and HKLM>system>currentcontrolset). I tried a repair install of windows to reinstall it, no luck there, reinstall SP2, still not in there, all dial up networking refuses to work (not that its any worse than before).

Oh well, format and reload it is.

This is a pretty serious design flaw in XP as far as i'm concerned. There should be a way of removing/reinstalling TCP/IP and all the WAN Miniport drivers. A fault like this should be 10 minutes work to fix.

Gene

Author

Commented:
Truly. But then again, it's no real suprise :-)

Commented:
I have been scouring the internet for a solution to this problem but have found none.  Basically, there is a particular variant of the Error 720 problem with IBM Thinkpads.  The problem is located in the PPP protocols/WAN Miniport/ TCP/IP protocols.  I don't know anything, so you guys can tell me whether these are all the same or different parts of the DUN connection process.  

Anyway, it appears as though either the 1) Thinkpad Access Connections Software screws it up or 2) the way the WAN Miniport drivers for OEM Windows XP are installed by IBM is different that with Windows XP.

It seems as though dealing with #1 has helped some, but for others #2 has been isolated as the culprit.  I have searched around and reseting the TCP/IP does not work because it resets to the original, incapable IBM protocol.  The other solution is apparently to do a clean reinstall of Windows XP.  Obviously, I don't want to create another 2 days of work reinstalling everything on my laptop just so I can have broadband access via my verizon phone.  

I hope this helps someone with more expertise than me to find an easier solution.  A lot of people with Thinkpads, Verizon and XP are suffering when it comes to dial up networking.
Have you tried uninstalling and reinstalling your network
adapter?
As for the INF file, look in C:\WINDOWS\inf\netrasa.inf.  r/click this and uninstall
Take a look here
VPN Client Cannot Establish a Connection After You Install a Service Pack
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. If you want your PPTP client that is running Windows XP SP1 or Windows 2000 SP4 or later to allow connections to a PPTP server that replies by using a different IP address, follow these steps to disable PPTP address validation: 1. Click Start, and then click Run.  
2. In the Open box, type regedit, and then click OK.
3. In Registry Editor, locate the following subkey
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<000x>
where <000x> is the network adapter for the WAN Miniport (PPTP) driver.
4. On the Edit menu, point to New, and then click DWORD Value.
5. Type ValidateAddress, and then press ENTER. The default setting for this value is 1 (on); therefore, by setting it to 0, you turn it off.  
6. Quit Registry Editor.
7. Restart your computer.

http://support.microsoft.com/kb/810839

How about this dspinto: post a request in CSG community support general
http://www.experts-exchange.com/Community_Support/General/
and ask to close and refund since we couldnt solve it and then repost this in IBM Laptops /notebooks   zones as this zone is new and has little traffic.

http://www.experts-exchange.com/Hardware/Laptops_Notebooks/
http://www.experts-exchange.com/Hardware/Laptops_Notebooks/PCMCIA/

You can post your question to 3 zones, dont give up yet just expose your questions to more zones to get the max exposure of experts, its the long week end in America now so things will be slow if you live over there.
Regards Merete

Commented:
Not sure what you mean about closing and refunding the points since I think it is worth 0, but I think I posted it properly now in a three zones. ID: 22980898 ID: 22980890.  This is my first post (Joined recently) so let me know if I did it right.  Thanks.
about closing and refunding the points<< is to your self.
 take a read thru the help it answers everything
http://www.experts-exchange.com/help.jsp#top,
 I see you posted your question in community support general you just ask them to delete this one add the URL, don't post the actual question  :)

Nobody answered my question. What do I do?
http://www.experts-exchange.com/help.jsp#hi71
 then re post your question.
Question Wizard
http://www.experts-exchange.com/help.jsp#hi344
They will help you now, show you how.
Regards
Merete
I've got this problem also and can tell excactly when it happend.  I installed Avira Antivir Premium and deinstalled it. This version of antivr also has a firewall. After deinstalling it I can't use dial-up and vpn connections anymore.
I think it is worth 0,<< thanks a lot that does help motivate me to offer my assistance, I do this on a volintary basis like all experts here .

Check your internet connection is in network connections. R/click one and make default.Could be any number opf things when something worked once a long time ago, updates often chamge a lot of settings.
To access a computer remotely is not really related to your modem other than the internet connection part is extablished. So check if you can access the internet via your modem.
You have the events and erros to check for any problems in control panel administrative tools., in windows on every page is HELP.
Or at start Windows HELP, fixing a problem >> then networking> in XP pro >>diagnose network configuration  and run automated tests

I have tried installing four different drivers<< probably too many and some driver maybe holding on.
Try safemode uninstall the modem.
You coudl even remove the modem card if it's not onboard the mainboard to completely remove it.
Remove any ethernet cables so that you have a clean start.
Commented:
I am experiencing the same issues with the following computers, Lenovo T61, T60 and Lenovo 3000 N100 laptops, I am starting to believe its something  related to IBM drivers as I found the problem always lies in the WAN Miniport IP and PPTP ports only in IBM machines. Here is a list of instructions that work for me for about 15 machines now and I think I got it pretty close. I've read alot on this issue and have done about 6 months of troubleshooting to come up with this solution.

VPN Error 720: No PPP control protocols configured

To resolve this issue, remove the WAN Miniport IP and the WAN Miniport PPTP device, and then reinstall both Miniports.

1.      Delete the VPN connection
2.      Click Start, click Run, type regedit in the Open box, and then click OK.
3.      Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}
4.      On the File menu, click Export& choose a destination and give it a name, and then click Save.
5.      Click each of the registry subkeys under this key, and then view the Data column of the DriverDesc value to determine which of the subkeys corresponds to WAN Miniport (IP). And the one that corresponds with WAN Miniport (PPTP). For example, the 0005 and 0008 subkeys.
6.      Right-click the subkey whose DriverDesc value data is WAN Miniport (IP) (for example, right-click 0005), and then click Delete. Click Yes to confirm that you want to delete the key. Then do the same for the subkey whose DriverDesc value data is WAN Miniport (PPTP).
7.      Close Registry Editor
8.      Right-click My Computer, and then click Properties.
9.      Click the Hardware tab, and then click Device Manager.
10.      On the View menu, click Show hidden devices.
11.      Under Network adapters, right-click WAN Miniport (IP) and then click Uninstall. Click OK to confirm that you want to remove this device. Repeat this step for WAN Miniport (PPTP) as well.
12.      Reboot the PC
13.      Find netrasa.inf in C:\Windows\inf, Open and place a semicolon in front of the line that starts "Excludefromselect=\" and end with "MS_NdisWanNbfIn,MS_NdisWanNbfOut" under the [ControlFlags] section. (all lines between)
14.      Click Start then Control Panel.
15.      Go to Add Hardware.
16.      Click Next, then select Yes I have already connected the hardware, then click Next.
17.      Scroll down and select Add a new Hardware device, click Next.
18.      Select Install the Hardware that I manually select from a list (Advanced), click Next then select Network Adapter in the list and select Next.
19.      Select Microsoft in the left column and then select WAN Miniport (PPTP) and click Next
20.      Select Continue Anyway, Click Finish and close out of everything. Now do the same thing for  WAN Miniport (IP).
21.      Uninstall, then Reinstall network adapters.
22.      Click Start, Run, type in netsh int ip reset resetlog.txt and click ok
23.      Reboot the PC.
24.      Uninstall and reinstall the VPN connection and this should fix the issue.

Some times I have to repeat steps 22 and 23 a 2nd time for it to work. Let me know if this was any help or any other errors that occured after attempting the steps above.


Commented:
has anyone followed up on this issue? I have just spent 4hrs troubleshooting and can't make this work! I also have an IBM T42.

Commented:
I tried the above soluton on a T61.  I was able to get to step 11.  When I tried to unistall the mini port devices i could not as I was given an error message that the system would not boot with out them.  Any other ideas.  Now in addtion to the verizon not working the PPTP vpn gives us the same error now!

Any help would be appreciated.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial