Trusted Sites button greyed out in IE7 for Windows 2003 Terminal Server domain users sessions

wiseman4250
wiseman4250 used Ask the Experts™
on
TS clients on a new Windows 2003 server R2 Terminal server have Trusted Sites button greyed out in IE7.\
No GPO is being applied in AD.  The local GP has not been modified.  Administrator account has full access to the IE security page/ buttons.  How can I enable adding trusted sites for all users of this ts server?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You might try:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings\Zones\2

Look in the right pane for a value named "Flags". Double click it and set the value data to 47 (hexadecimal). Be sure to back the key up first to be on the safe side.

Author

Commented:
The flag key in HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings\Zones\2  is currently at 47.  No change necessary.

Thanks aprilmj

Author

Commented:
Here is the solution:
 
I modified my GPO in the Terminal Server Users OU in AD with the following:
 
"User Configuration" -> "Windows Settings" -> "Internet Explorer Maintenance" -> "Security". Right click on "Security Zones and Content ratings" and select "Properties", Import the current security Settings.
 
Forced GPO updates with secedit /refreshpolicy user_policy /enforce    (W2K DC)
 
This enabled sites to be added to the different zones on the security page.
This also removed the key emblems from the icons on the security page for the users

Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

Commented:
I am currently having the exact same problem however my users are local users on the TS server and there is no AD OU GPO that I can use to address this issue on the local users.  Does anyone have any other suggestions?  Users created earlier than yesterday(??? how long I'm not usre) seem to be fine.  

Commented:
I'm having the same problem with local users too. It is only for new users and not specific to what type of user (even Administrators). This is the first time I have tried to add a user this month so it could coincide with the report from 06.08.2007

Any Ideas would be more than welcome!
Commented:
Actually, after working with Microsoft it was concluded by Microsoft that the problem was caused by a Windows Update to Windwos 2003.  The Default User profile had become corrupt.  I also found that there were some wierd user profiles with .WINDOWS appended to them.  The solution that has worked (not a true fix but at least a work around) was to take 1 profile that was correct and using the COPY TO feature under User Profiles overwrite the Default User profile.  This seemed to solve my problem.  The general consesus at Microsoft was to NOT delete the wierd .WINDOWS profiles since they just weren't sure why there were there.  As much as I don't like what happened, I must admit, Microsoft went the extra mile to help me solve this situation.  Hope this helps you

Commented:
That's great the work around get me through what I needed. It isn't ideal because it take a lot of other settings with it but at least it makes it workable. Thanks a lot!

Commented:
Your welcome keyswiss.

Commented:
Okay but this means that all users that are already created would still have to be cahnged manually?

Commented:
Yes, that is correct.  All existing users will have to be changed manually.

Commented:
Someone pointed me towards
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3149964&SiteID=17

Which made it posible for me to change the trusted sites for all the users.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial