Wrong country/region in Outlook 2007 contact's telephone numbers

ivolach
ivolach used Ask the Experts™
on
I am running Outlook 2007 on a Vista computer.
When I create a new contact and enter telephone numbers, it assigns them to a different country/region than my default vista country region (Canada)
How can I change the default country/region for Outlook?  In Outlook 2003 it added +1 to the number and formatted it properly for North America (xxx) xxx-xxxx

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2008

Commented:
Greetings ivolach !

http://office.microsoft.com/en-us/outlook/HP101741311033.aspx

In Windows Vista
   1. Click the Start button, and then click Control Panel.
   2. Click Clock, Language, and Region, and then click Change the date, time, or number format.

       Note   In Classic view, double-click Regional and Language Options.

   3. On the Formats tab, select the country/region that you want to use in the list under Current format.


Best wishes, war1

Author

Commented:
On the format tab, the current counrty/region is English (Canada)
On the location tab the location is Canada
and yet Outlook seems to 'think' that the default region is Israel (only in Contacts/telephone numbers)
Top Expert 2008

Commented:
Regional Settings are control from Windows regional settings. Are you using an Israeli version of MS Office or MS Outlook?

When you change the country/region in the Your locale (location) list, settings, such as the format for displaying contacts telephone number, may also change. Check all the tabs in the Regional Options dialog box to make sure they are correct.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I have checked them all and they are all setup right.
I have changed the country/region to Israel, applied and then changed it back to Canada still the same results.
The interesting part is that the default country/region for the address comes up correctly as Canada, it is only the phone number that picks up the wrong country

I am using North American Vista & MS office

Author

Commented:
I have found the problem.
I had to change the location in the telephone & modem setup:
Control panel -> phone and modem options -> dialing rules -> my location.

Thanks
Top Expert 2008

Commented:
ivolach,

Glad you found the telephone numbers.  So they were kept in a different file in a different location?

Author

Commented:
Apparently the phone number format in Outllook follows the locale selected in phone & modem settings and not the one in the general windows settings.

Thanks for your help
Commented:
PAQed with points refunded (250)

AnnieMod
Cleanup Admin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial