IIS 6.0 Authentication Mode

cuconsortium
cuconsortium used Ask the Experts™
on
Dear all,

  I'm running IIS 6.0.  I would like to have the IIS 6 Server only allows Domain Users to view certain pages on the web site ( Domain Users will be prompted to enter Domain Uid/psw before viewing the website ).   First of all, I'm not quite sure how to do so in IIS 6.0.  However,  I went to the page's Authentication property and test out the available authentication mode, none of them works.  I eventually unckeced all the check boxes on the page's Authentication Property.  I expect it would show "unauthorized access" when I access the page. But, the page is able to display sucessfully even though nothing is checked on Authentication Property.

   Could anyone tell me what's going on?  How do I configure the IIS 6 Server, so that it would only allow Domain Users to view certain pages on the website( Domain Users will be prompted to enter Domain Uid/psw before viewing the website ).

Thank you!!!


Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Toni UranjekConsultant/Trainer

Commented:
Hi!

One question: You unchecked even anonymous access and you can still access the web page? Did you clear the cache of your browser?

Toni

Author

Commented:
Hi Toni,

  Yes. The internet temp files, history, cookies are all deleted.  And the page was displayed without problem....  anonymous access was unchecked....  :(   Any ideas?

Thank you.

Author

Commented:
By the way,  It's IIS 6 running on Windows 2003 Server.  
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Author

Commented:
Another By The Way,  ....

At the WebSite level, I have "Enable Anonymous Access" and "Integrated Windows Authentication" CHECKED.

At the Page leve (the page that I wan to restrict access), I have Everything is UNCHECKED.

Thank you!
Toni UranjekConsultant/Trainer

Commented:
Can you explain if "page" is virtual directory?

Author

Commented:
Hi toniur,

  The page is in default directory(Inetpub) of IIS.  It's not anywhere else. I don't think I created a virtual directory for the web site.  I just put it in C:\Inetpub...

Thank you.

Author

Commented:
Now it's very strange.

I tested another page for Basic Authentication only.  Then restart the server.  The result is:

I use IE to access the page, the Status bar in IE shows "Opening Page http://bluh... ....  "  , and the page never gets open, the browser just keep opening page and never get to the page.

I use Firefox to access the page, it's able to view it without and pop up asking for User Name and Password.

Any ideas?  I don't understand why it's having so many problems to config a simple thing.

Thank you!!

Author

Commented:
Hi toni,

  To be accurate for your "virtual directory" question:

In IIS Admin. console, on the left hand side, there's an earth icon that represents my web site, and it is at the same level of the earth icon that represents Default Web Site.  If I right click on the property of the earth icon that represents my website, I can see the Local Path is specified in C:\Inetpub\wwwroot\myfolder.

So, does my website have a virtual directory?   The page that I want to restrict access is in "Myfolder" directory.

Thanks.
Consultant/Trainer
Commented:
I guess you have two web sites, if you want to restrict access to "myfolder" site, right-click site, select Properties, go to Directory security tab, click Edit... button and clear ALL check boxes. You should be getting at least "You are not authorized to view this page" at this moment.

Author

Commented:
Hi tonie,

  It happens that my site is located under the default site, at the same time, there's another "Earth" icon for the my web site.  Whatever I did under the "Earth" icon for my website is overwitten by the Default web site's security access.

Thank you.
Toni UranjekConsultant/Trainer

Commented:
Right click "Earth" icon under your Default web site, select properties and change security settings.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial