Change the shadow users setting for Citrix to not require the user's permission

mikeorm
mikeorm used Ask the Experts™
on
I have a Citrix server environment w/ 2 servers.  Presentation server 4.  I need to enable shadowing w/ full access without asking the user's permission.  During the install, the remote control/shadow option was incorrectly set to require the user's permission.  Reinstalling Citrix is not an option.  How can I change this setting?  Or is there a way around it so I can shadow users without asking the user's permission?  Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
according to citrix, and from everything else I've seen there is no way to do this without reinstalling.  Someone else might post a workaround or hack but I don't think it's very likely (although I've been wrong on occasion).  If someone does know, I'd like to know how also.
Commented:
Is this a 24/7 operation?  You can load balance all apps to one server, uninstall ctx, reinstall, repatch, rebalance apps and have a server back up and running in about 2-3 hours.  Everything is preserved in the farm.  I don't see how you cannot reload Citrix...or was this a contract thing, you finished, and you are not going back?  
Have you tried creating a policy in Citrix that defines your settings?  Create a policy, under User Workspace, Shadowing, Configuration, enable the policy and set to Allow Shadowing and leave the Notification box unchecked.  This might work.  
On the other hand, I have heard of this issue before and I have always seen people resort to a reload of Presentation Server.  
If done correctly, reloading PS is a minor thing.  You get a fresh install and you can repatch to exactly the level you need; nothing but positives.  

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial