Configuring the QoS for good voice quality on a Cisco Switch

firewired44
firewired44 used Ask the Experts™
on
I'm looking for good examples of QoS configuration for my switch :
I have VoIP communications going through a Cisco 3500 series XL switch, however the sound quality of my phone calls are very bad.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You can use the Auto Qos feature to configure Qos
http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/swqos.htm#wp1202069

Auto qos voip {cisco-phone | trust}
Top Expert 2007

Commented:
Is the voice quality an issue from phone to phone within the same switch? Are you using voip to connect to a carrier such as vonage?

Most of the time voice issues emerge from wan or internet links and not within a switch. Don't get me wrong its best to mark traffic as close to the source as possible and to properly manage voice thru your network but it sounds like all your callers are on single switch.

Author

Commented:
Yes all my phones are on the same switch, it's a local VoIP network.
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

Author

Commented:
Thanks Louis E. I'll try that as soon as I arrive at work.

Author

Commented:
After checking my switch I saw that my IOS doesn't seem to have an auto qos feature.

So I tried setting it myself with the following configuration, I assigned these settings to each port connected to a VoIP phone on my switch and also on the port connected to my Call Manager. But after my VoIP phones can't reconfigure themselves and keep requesting an IP from the DHCP. Any ideas why this is happening ?

configure terminal
interface interface
***********************************
switchport voice vlan dot1p
**********************************
Instruct the switch port to use 802.1p priority tagging for voice traffic and to use VLAN 0 (default native VLAN) to carry all traffic. )
end

      
Top Expert 2007

Commented:
a few things I see,
the native vlan is 1
you can create a second vlan to carry voice, we'll use 2 in this example

In doing this you must make sure there is a router to route between the vlans and you need to make sure that you have connectivity to your call handler

At the config prompt

vlan database
vlan 2 Voice
Vlan 2 state active
exit

interface vlan2
ip address x.x.x.x
exit
interface f0/1
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
exit

This is a very basic port configuration for setting up a vlan for your phone.

What type of phones are you using and what are you using for phone system?

Author

Commented:
I'm using Cisco 7960 phones and I'm using Call Manager Express 3.3 running on a Cisco router connected to a port of my Cisco switch. Thanks I'll try your configuration it seems exactly like what I'll need.

Author

Commented:
I re-read one of your answers, actually yes, the quality is fine between the VoIP phones calling each other on the same switch. The sounds quality issue arises when I'm dialing regular and ISDN phones that aren't connected on the switch, but on my PABX.

The network of the office looks like this

(PSTN) -- (PABX) -- (Cisco Router with Call Manager Express 3.3) -- (Cisco Switch)
Commented:
So you experience this problem when the call passes through the PABX?

Sounds to me like it might be a codec problem.
Make sure that the PABX and CME are using the same codec G711ulaw is recommended if you have enough bandwidth available between the cme and pabx.
Top Expert 2007
Commented:
Then on the router you would a config something like this

interface FastEthernet0/0.1
 description " Local Data VLan "
 encapsulation dot1Q 1 native
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
 description " Local Voice VLan "
 encapsulation dot1Q 2
 ip address 192.168.2.1 255.255.255.0

On the port connecting the router to the switch you would have something like this:

interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk

Hope this helps
B
Top Expert 2007

Commented:
Sorry last post was delayed between writing and hitting submit.

How are you connecting to the PABX?

Author

Commented:
Thank you for the switch configuration bfason, I will configure test that on my switch.

But yes now that Louis E. mentions it, it would make more sense that it is a codec related problem..

Here are the dial-peers i'm using, the first one works so i can call numbers on the pabx by typing
0200, 0201 etc.. And i always get bad sound quality and noticed that my calls only go thru to ISDN phones, the analog ones don't receive my call.

dial-peer voice 2 pots
 preference 2
 destination-pattern 0...
 port 0/0/0

This dial peer is supposed to work for outgoing calls to the PSTN, (they first pass through the PABX to reach the PSTN), but i'm having trouble getting this to work, please note that I'm in a euro country and am supposed to use the g711alaw codec.

dial-peer voice 11 voip
 translation-profile outgoing outgoing-call
 destination-pattern 00.........
 session transport udp
 dtmf-relay h245-alphanumeric
 codec g711alaw
 no vad
!


 Here's my Cisco router's CME configuration in case you want to check other settings, I have removed some lines that would not be relevant to the problem. thanks a lot for looking into all this !

Current configuration : 6207 bytes
!
! Last configuration change at 10:50:29 GMT Tue Jun 6 2006
! NVRAM config last updated at 10:49:21 GMT Tue Jun 6 2006
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CiscoCME
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$Hl0k$fJDNe3h5ov4J8Fq64F4Hp.
!
clock timezone GMT 1
clock summer-time GMT recurring
network-clock-participate wic 0
no aaa new-model
ip subnet-zero
!
!
ip cef
ip dhcp excluded-address 172.24.10.1 172.24.10.9
ip dhcp excluded-address 172.24.10.51 172.24.10.254
!
ip dhcp pool test
   network 172.24.10.0 255.255.255.0
   default-router 172.24.10.1
   option 150 ip 172.24.10.1
!
!
no ip domain lookup
no ftp-server write-enable
isdn switch-type basic-net3
!
voice-card 0
 no dspfarm
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 supplementary-service h450.12
 h323
!
!
class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
!
!
policy-map output-L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
!
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address 172.24.10.1 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
!
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving T302 2000
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing-voice info-transfer-capability 3.1kHz-audio
!
interface BRI0/0/1
 no ip address
 shutdown
!
ip classless
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
ip access-list extended bri
 remark SDM_ACL Category=1
 permit ip any any
!
!
control-plane
!
!
!
voice-port 0/0/0
 cptone CH
 connection plar 318
!
voice-port 0/0/1
!
!
dial-peer voice 2 pots
 preference 2
 destination-pattern 0...
 port 0/0/0
!
dial-peer voice 11 voip
 translation-profile outgoing outgoing-call
 destination-pattern 00.........
 session transport udp
 dtmf-relay h245-alphanumeric
 codec g711alaw
 no vad
!

Author

Commented:
I fixed the problem! Now the voice quality is fine, the problem was codec related.

I simply added on my voice-port 0/0/0 the following line :

compand-type a-law

(it would have been u-aw if I was in the US)

Thanks again for your advice !

Commented:
Not a problem....glad the problem was fixed.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial