Remote Desktop Connection - Specified computer could not be found

Lisaa_G
Lisaa_G used Ask the Experts™
on
Just set up a wireless router (Linksys 2.4GHZ  802.11b with four port switch) on a home computer - it was previously set up with only a cable modem.  Internet connections are fine and I can establish a VPN connection to the user's work network however the Remote Desktop Connection is returning a error saying the specified computer could not be found.

It worked fine before I set up the router so I'm assuming I've done something that changed things....  what did I miss?

(Both computers are running windows XP)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Are you trying to RDP using the work PC name or it's IP address?  Can you ping the PC?  If you can't ping it you won't be able to RDP to it.

Was RDP working between these 2 PCs before you swapped the modem with the router? or is this a new setup?  I'm trying to figure out what may have changed in your setup if it worked before.

Author

Commented:
Trying to RDP using computer name (previously saved connection).

Yes the remote desktop connection was working before I set up the router.

Commented:
Find out what the work PC IP address is (from command prompt type "ipconfig") and try to ping it.  If you can't ping it, you can't RDP to it.  If you successfully ping it, try RDP to IP address instead on name.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
At work they may also be having DNS problems (or old info in cache) so once you find out the IP addr. try to ping the name (from cmd prompt "ping PCxp001" and this should return the IP it's trying to ping) and check to see if the IP addresses match (DNS is resolving correctly).

Author

Commented:
Can't ping it by number or name.

I also now seem to be periodically dropping the internet connection on the workstation where I've added the router.

I'm going to return to the original configuration for now so this poor guy can work but he wants to have an additional PC using the internet so I'm going to have to try the router again...  

Anything else you can think of - I'd be pleased to try.

Strangely there seems tobe no trouble establishing VPN connection.

Author

Commented:
OK - I've disconnected the router.

I can now ping the work desktop by number and by name.  When pinging by name it returns the same ip address I was expecting.

VPN / Remote Desktop work fine.

It's got to be something with the router but I don't know what!!!!

Commented:
How have you tested the VPN when connecting using the router to ensure the VPN is fully functional? Are you able to ping anything on the work network?  Are you using the Windows VPN or other VPN?  What model Linksys are you using?
Top Expert 2013

Commented:
The machine to which you are connecting may have a firewall enabled. The Windows firewall, for example, when you enable remote desktop, automatically creates an exception, allowing remote desktop connections. However, only from the same subnet. Where you are connecting over the VPN you are connecting from a different subnet. As a test disable the firewall, or you can add a subnet or all locations;  control panel | windows firewall | exceptions | highlight remote desktop and choose edit | highlight 3389 and choose change scope | add your subnet, or choose all computers (including those on the Internet"

It may be the problem as an enabled firewall will result in an "specified computer could not be found" error. The same can apply to other software firewalls such as Zone Alarm, Symantec Security Suit, etc.

Author

Commented:
Gentlemen,
May be a day or two before I'm back at the right location to test your advise but I'll let you know.  Thanks for your assistance.
Top Expert 2013

Commented:
Let us know how you make out.
Cheers !

Author

Commented:
Good afternoon gentlemen!
I'm finally back to this problem.

RobWill - Have checked all firewall settings at destination computer for remote desktop connection - they are as you specified they should be (I did not have to make any changes).

Myin68 - I'm using windows VPN - I time out when trying to ping the computer on the work network.
The linksys is a model BEFW11S4.
Top Expert 2013
Commented:
You mention you can connect the VPN without any problem, but can you access anything at the remote site, or ping anything at the remote site ?
If the new router changed the local LAN subnet, and it happens to be the same as the remote site's subnet, you will be able to connect the VPN but not communicate with anything except in some case, the VPN server/device. Might both sites use something like 192.168.1.x ? They must be different for a VPN to work.
Commented:
Got this from the Linksys user guide (PDF document).  Make sure you've implemented these steps to allow the VPN in the new router...

The Security Tab - VPN Passthrough
Use the settings on this tab to allow VPN tunnels in either IPSec or PPTP protocols to pass through the Routers firewall.
IPSec Passthrough. Internet Protocol Security (IPSec) is a suite of protocols used to implement secure exchange of packets at the IP layer. To allow IPSec tunnels to pass through the Router, click the radio button beside Enabled. IPSec Passthrough is enabled by default. Click Disabled to disable the function.
PPPoE Passthrough. Point-to-Point Protocol over Ethernet allows your PC(s) to use the PPPoE client software provided by your ISP. Some ISPs may request that you use this feature.To allow allow PPPoE Passthrough, click the radio button beside Enabled. PPTP Passthrough is enabled by default. Click Disabled to disable the function. PPTP Passthrough. Point-to-Point Tunneling Protocol is the method used to enable VPN sessions to a Windows NT 4.0 or 2000 server. To allow PPTP tunnels to pass through the Router, click the radio button beside Enabled.
PPTP Passthrough is enabled by default. Click Disabled to disable the function.
Change these settings as described here and click the Save Settings button to apply your changes or Cancel
Changes to cancel your changes.

Michael

Author

Commented:
Thanks again gentlemen - I'll try to get back out tomorrow to try your latest suggestions.  Appreciate your patience in bearing with me.

Lisa

Author

Commented:
Gentlemen,

Thanks for your patience on this one - I ended up with two problems - primary problem turned out to be the local lan subnet - secondary problem proved to be a faulty router that would not save changed settings (I'm embarassed to say how many attempts I made before I realized it).

Everything is working well now - thanks!
Top Expert 2013

Commented:
Thanks Lisaa_G.
Cheers !
--Rob

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial