Unable to connect to my mail server.

vsaraogi
vsaraogi used Ask the Experts™
on
I am unable to connect to my mail server. I tried everything, created a connection document, able to ping, tried to connect with IP address, disabled firewall. I am using R7 client. Can someone help me on this.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2007

Commented:
SO, this was working before ?

1) DId you disable your firewall on your computer ?
2) Did you delete the connection doc and then try to open the server using - file- database- open, and using the correct IP address ?

3) Did you delete the cache.ndk file ?

I hope this helps !

Notes Uses Port 1532 make sure that this port is open on your firewall.. Ping uses a completely different port.  Just because you can ping does not mean port 1532 is open

Try opening a DOS window and typing

Telnet ServerNameOrServerIP 1352

If you get a boring black screen with no error message you were able to telnet to the server using that port

Author

Commented:
I am able to telnet. Interesting thing is that I uninstalled r7 and installed again in notes\data folder and it is working fine now. Able to connect to my mail server. Earlier I installed Lotus Notes in r7 folder. Any suggestion.
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

The only thing that I can think of is that your Notes.ini file was not pointing at the R7 Folder.  Not knowing what type of install you did perhaps you did not have a pointer to the correct ID file which would have caused you to not be able to authenticate with the server.  It would be perfectly feasible to do an install where you actually created an ID file out of thin air that had no relationship to the organization at all.  Sometimes you have old outdated ID files on a machine..

There can be multiple causes..  I always like to put the ID file in the Address book temporarily and have the user put in the connection information when they do the setup.  It makes it slightly easier to see where the cockups are occuring..   The most complicated thing about notes is that it uses double key encryption on time sensitive ID files.  This makes your data incredibly secure... WAAAAAAAY more secure than any microsoft product... but it is a pain in the but to make sure that you have the right id file talking to the right server.
Top Expert 2007

Commented:
I agree that installing into a different flder than the previous may have messed things up a little.
SOmetimes the upgrade does not recognize the previous installaton ad that can cause issues.

Glad you got it working !

Author

Commented:
I am using the same ID as I was using in previous installation in R7 folder. So id should not be an issue. I am not sure what do you mean by what type of installation. I installed the standard one with all the three clients (Notes, Designer and Administrator).
Notes installation creates a new Notes.ini file automatically in installation folder automatically. So not sure if notes.ini was pointing to wrong folder. Could it be a resigtry issue ?
Im sorry I should have been more clear.. there are several methods that you can use to do a Notes Client Install..

Method 1 is the one that I prefer and that involves putting the client ID IN the address book temporarily then I specify the server and address information while I am doing the install and the Notes Client downloads the ID into the prefered location during the install process...  I like this method because any problems will become apparant immediatly.

Method 2 is to use a Notes ID that is on the workstation and specify the location of the ID during the install and Notes will get the information from inside the Notes ID and will use that information during the install process..

Method 3 is to get an image or an install where you don't use the Server or the ID and you just build the Location Document and Notes.INi file by yourself.

How could there be a meaningful difference between one folder and another???  It is a strange problem..  

One possibility would be that things that Point to locations could be off or perhaps the things that they point to could actually be different.  Your notes.ini file specifies the location of multiple items.. if this was off then that could be a potential problem  OR there could be (although we now know there are not) more than 1 ID file and the Notes.ini file from 1 install pointed to one id and the install in another folder pointed to another.  Another possiblility is that One of the folders was in your Systems PATH setting so files in that folder are readily acessible even if pointer information elsewhere is a little off, the PATH statement at the system level would make everything accessible even if there were bad pointers.  Another possibility is that You have a firewall that will allow the Notes.exe program to communicate through the firewall but when the exe file was in another folder it no longer matched the rule in the firewall so it was blocked.  If you have a notes.ini file that is in a folder in your path statement that can be a pain because you might be reading from the wrong one

Connectivity problems are a major pain in the butt to troubleshoot because it is all process of elimination..  Generally if you have a personal firewall it is best to stop it for a while if you can.. This is just to see if that fixes the issue you can always fix the rules once you know it is the culprit..  

The first place to look is at Ports under user preferences you would have wanted to make sure that TCP/IP was activated and then you would have wanted to do a trace to see what information you get back about the failure.

Sometimes you can see that the TCPIP address is not found or it is trying to use a bad one.. then you have to figure out where the bad data is comming from....

If there is a connection document being used the Trace will uncover that.. If TCPIP just fails to resolve then you need to check the ability of the TCPIP to communicate with the server which you did using telnet..

There are so many different possibilities that it is really hard to say exactly what caused it without going through trial and error.. Those are some possibilities above..  If you help with help desk calls you will get people with those problems.. If you want to try moving it to another install directory again we can try to see what the problem was.. But it is a process of troubleshooting.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial