Avatar of aaronDressler
Flag for United States of America asked on

1GHZ 17in. PowerBook G4 doesn't turn on, boot, or do anything...

Hi..  I just got a 1Ghz 17in G4 PowerBook handed down to me.  It was shipped Next Day from my mom by UPS and was really REALLY well packed.  She had it running the day she sent it out, to delete her personal files.  When I turned it on for the first time, I plugged the AC adapter into the wall and the light on the charger went to orange as expected.  I tried to turn it on by pressing the power button, and absolutely nothing happened.  My mother had experienced slow booting issues when she had it (she would press the button and nothing would happen for about 10 seconds, then it would turn on, and everything would work fine).  But this time absolutely nothing happened.  I let it sit there and charge (thinking it might have been an extremely dead battery..) and went to try again, with no luck.  Nothing happened.  I unplugged the computer from the wall and took out the battery.  Then I plugged the comp back into the wall and tried starting it with no luck.  Then I looked at the apple webpage and they suggested reseting the PMU (Power Management Unit)..  Tried that, didn't work.  So, I guess I'm just one step short of taking it into apple and paying to see what's wrong with it...  Any ideas??

Apple HardwareApple OS

Avatar of undefined
Last Comment

8/22/2022 - Mon

Oh...  I forgot to add that when I press on the battery life LED on the bottom of the powerbook, nothing happens as well..  even though the battery was charging for 3 hours.  The battery isn't even hot.  And I tried hooking it up to another AC adapter with the same results.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

Hey Pheidius...

Yea, I'll check the memory and the firmware battery..  I don't think there is any video signal from the laptop, but I will plug a monitor in to find out..  I really don't understand why it won't turn on when just connected to the wall.  I plugged it into a power strip, so I know that it was working cuz the TV was on..  and I tried a couple different outlets.  My mom sent a car charger for the laptop in the box too..  I even started up my car with the comp plugged in to see if it had a change of heart...  but no luck.  

It has OS 10.4 installed.  I read those articles you sent...  And I think the second one holds the answer...  According to the first article, it can't be my DC In Board becuase I still get lights on my AC Adapter (it turns orange when I plug it in).  I did everything else on the list, except for the last, and definitely least enjoyable option, faulty logic board...

I'll try those things you suggested, but I have a feeling I'll be picking up a new logic board soon.  Thanks for all the help.


Hey, thanks for your help once again...  I can now say I've tried everything...  And it looks like I'll be taking it in to apple for a new logic board...  thanks for the links and suggestions, they were a real help.

I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck