Link to home
Create AccountLog in
Avatar of bacchus1106
bacchus1106

asked on

OWA redirecting to internal name of Exchange server

We have a Windows 2003 Server 64bit running Exchange 2007. This is a new install. We have an SSL certificate installed on the default website. Now for the issue.

When accessing OWA @ https://mail.domain.org/exchange from the outside I am unable to get to OWA. I can however get to https://server/exchange from inside the network. I have uncovered the following:

When I use IE I get a page cannot be displayed with no additional information. When I use Firefox I get redirected to the address https://server.domain.local/owa.I have noticed that when i type in the addess the Exchange virtual directory is redirecting me to the owa directory but it appears to be using the internal name of hte server. Which of course is not accessable from the outside. Any ideas?
ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of bacchus1106
bacchus1106

ASKER

That may indeed be my problem. I may not have done enough research with Exchange 2007 and OWA's Virutal directories. I have not set URLs on the virtual Directories though. How do you mean? I guess I could hunt down the answer but if you know off the top of your head or could explain it more I would appreciate it.
It is set in the GUI. There is an external and internal URL option which should be set on the virtual directories for OWA.
E2007 is more complicated to setup than the previous version.

Simon.
Gentlemen, I know this is an old post, but wonder if there is a similar solution to this on Exchange 2003 SP2 without having to have a front end server.

malboteju - as this is about Exchange 2007 not Exchange 2003, and is over 18 months old, I would suggest that post your query fresh. It isn't possible to bump questions, so the only people who see the post are those that have already participated.

Simon.