We help IT Professionals succeed at work.

Team Speak server/client setup

dcs911
dcs911 asked
on
2,895 Views
Last Modified: 2013-12-26
I am experiencing some issues with an application called "Team Speak". I have been able to setup the server on ym computer. I have also been able to connect my own account to that server from the same machine. However, my friends who wish to vocally chat online while we surf or game, are having difficulty getting connected. The error message is as follows:

Either the server you are trying to connect to does not have teamspeak installed or it is not working properly"

Or something along those lines. I believe it has to do with THEIR port-forwarding or their UDP ports, but I am not sure how to explain it to them in a simple way. Please, if you know what I am talking about please let me know if you have a solution or a simpler alternative. I did attempt to substitue it for Ventrilo, but I had trouble understanding how to setup my ventrilo server, so I moved on to Team Speak.
Comment
Watch Question

Hi,

I've used both Vent and Team speak.
I have a TS server running and it works fine for people connecting in.

You have to make sure your port forwarding (you as the server) is set up correctly. (Assuming you have a router and not just a direct connection to the internet)

If you have Port Forwarding set up, what ports are your currently forwarding for TS?

They should not have to set up port forwarding as the client as it's an outgoing connection and doesn't care about port forwarding.

I have had instances where friends haven't been able to connect but as soon as I turned off ZoneAlarm it worked fine.

It turned out Zone Alarm was stopping the incomming connections.

I would have sure your portforwarding is set up correctly and that it is allowing incomming connections through your firewall.
(even if you tell the Firewall to allow it there may be other rules stopping them from getting through so turning off the firewall for a few minutes and trying will help.)

Hope that helps,

Aikidoka

Author

Commented:
That helps clear some things up, but My firewall was disabled while this was going on so that I could ensure it wasnt a factor. Zone Alarm it is. The port that I chose to use is port 9292, which is setup on the server. I CAN connect to myself with it and get in the Team Speak setup, but nobody else can. You may have the answer I seek, but that one is a little bit vague on the client connection end. It is on a router and bellsouth fast access DSL. I need to check my router though, because I forgot it and checked my DSL because it acts as its own router. It has its own default IP of 192.168.1.254, and I think the router I have there is a NetGear.
Ok,
1) Have you set up port forwarding on your router?
2) Is the other party using the correct port to connect to your server? (9292)

(There should be nothing the remote computers need to do to connect to you other than filling in the correct IP and port - It is possible they are being blocked at their end by firewalls etc but if you have multiple people trying it's unlikely they're all being affected in the same way)

Aikidoka

Commented:
If your DSL has that type of address it is guaranteed to be acting as a router. You will need to set up port forwarding on the router from the external side to forward through to your IP address of your machine (should be 192.168.1.x). You will then need to give your friends the external IP of the modem. You should be able to find that out from inside the modem setup, or use a service like DynDNS ( http://www.dyndns.com/ ) to give your friends an address for your server that won't change.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Ok, I did setup up port forwarding and my I.P. hasn't changed according to the DSL and TS server software. They both recognize a 78.243.112.201:9292 or something like that, but other than myself nobody can connect. They find my server in the list, type in the password, and they get rejected. I did find that if I used quick connect and manually punched in the I.P. address, then it would fail for me as well, but as long as I searched it and went through the list, it allowed me to login, but only me.

Any other suggestions before I close this one?

Author

Commented:
I'm gonna go with this answer because it is the simplest explanation of proper port-farwarding, and it has an auto forward option as well as the external I.P. that I need. If it has to be one of these problems and this solves it then I am satisfied.
Strange...
Have you tried it using the standard ports TS suggests?
It might be worth trying that just in case.

After that, I'm not sure of what else to try without starting from scratch....
Maybe I'll try connecting to it sometime

Aik

Author

Commented:
Yes, I attempted it with the suggested port and got the very same results. I would say try to connect, but I scrapped trhe server and started over. Still nothing. I am currently searching for an alternative means of gaming communications that is simpler.
Ok, if you want, get in contact with me via my profile details and I can set up my server and with you connected talk you through the steps to take, in case anything's been missed by accident.

If not, good luck.

Aikidoka
If you still are having trouble I have a few suggestions that might be able to help
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.