We help IT Professionals succeed at work.

IOS versions & vpn traffic help.

buttino
buttino asked
on
390 Views
Last Modified: 2010-04-09
Hi,

I've got a question re Cisco site to site VPNs

We have an office in London using a PIX 506E, with two other sites in Germany & the US connecting with 501's. We're trying to install a 3rd site in Singapore using another 501 which is where the problems start.

The 501 in Singapore appears to have different IOS version - 6.3(3) where the others that successfully connect are using 6.3.(5), would the difference in IOS version prevent a successful connection?
Also, does the VPN come up automatically or does it depend in traffic initiating the connection before the link is made.

The reason I'm asking, is that there's currently no-one in Singapore to test the connection, but my config does appear to be correct as I've compared it against the US config.

Thanks

Trevor
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Below is the result of show cry is sa

Total     : 0
Embryonic : 0
dst               src        state     pending     created


This is the config of Singapore


interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxx encrypted
passwd xxxxxxxxxx  encrypted
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list external permit icmp any any
access-list inside_out permit ip any any
access-list split-tunnel permit ip 192.168.3.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list outside_cryptomap_5 permit ip 192.168.3.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 58.185.123.456 255.255.255.240
ip address inside 192.168.3.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNpool 192.169.3.1-192.169.3.254
pdm location 192.168.3.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group external in interface outside
access-group inside_out in interface inside
route outside 0.0.0.0 0.0.0.0 58.185.187.50 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map client authentication LOCAL
crypto map outside_map_1 5 ipsec-isakmp
crypto map outside_map_1 5 match address outside_cryptomap_5
crypto map outside_map_1 5 set peer 217.154.xxx.xxx
crypto map outside_map_1 5 set transform-set ESP-3DES-MD5
crypto map outside_map_1 interface outside
isakmp enable outside
isakmp enable inside
isakmp key ******** address 217.154.xxx.xxx netmask 255.255.255.255 no-xauth no-config-mode
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup remoteSI address-pool VPNpool
vpngroup remoteSI dns-server xxxxxxx
vpngroup remoteSI split-tunnel split-tunnel
vpngroup remoteSI idle-time 1800
vpngroup remoteSI password ********
telnet timeout 5
ssh timeout 30
console timeout 0
dhcpd address 192.168.3.100-192.168.3.200 inside
dhcpd dns 165.21.xxx.xxx
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80




Commented:
you have to have your debugs on.  since you are using pre-shared keys, i would confirm that both pix's have the same password

Author

Commented:
Debugs aren't showing anything at all, what I've read is that debug sends to the serial console port. I'm connecting via remote SSH in the UK, is there another command I need to actually see the output of the debug commands?

Author

Commented:
Good news! The line came online overnight, so it would appear the first solution answering my question was correct.

Thanks.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.